Introduction to Embedded Systems Design on FPGAs

Embedded system often refers to the non-PC systems which combines hardware and
software design. The development of FPGA technology brings advantages to the
embedded system in size, cost and performance. It is a hot application field which
merges logic design and processor-based hardware development in a single or few
chips solution. The merge of field programmable gate array (FPGA) technology and
embedded system design have great influence on the traditional design methodology.
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An FPGA consists of an array of programmable logic blocks interconnected by
programmable routing resources.
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Hands-on: FPGA design and run it on a FPGA development board

Implement a simple Boolean Equation X=AB+CD, and illustrate the steps involved to
design, simulate, and program a FPGA using Altera’s Quartus’ II software.

A. Create a new project:
1) Create a new project:
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2) Fill a name and top-level entity for the project.
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4) Select Cyclone Il family, and choose EP2C35F672C6 which is the FPGA used on
Altera’s DE2 board

r e —— e —r
T e e [ 02 1 L I eIy
Entty I
& Compdsion Herarcy|
OLLABORATE. D RA
s = = = = =
New Project Wizard: |
e e e [ e
e ' '
Famks  [epi | [roie B T
:I = D E R |
T T Tt dvice st [y ]
T  dur g @
5 I Anshyss § Syrthess 1 & Specic device selecied i Yvalable devices” izt I HarcCopy comastibe only
5> e e Pkl
» Ausente
- Timng Analyss Hame. Cosew. | LEs User /| wamor | Embed [ PLL
B e Dot o EraEaiS ER
 Progam D e Progrme EPCAN 12 162 142 BEE W2 4
s N Gk » kae » 4
HEs] i mme m osmeono 4
BEE o e m wem nm 4
£Foxzraag N oo e w4
g =
S R . —
%[ zwpe [ueszee
[ 1=l
o e B )
-. —_'? .- ! T W — - o g—ay— -
Ple Pt e Praec it~ Procesing ~Tooks~ Widem—Help
DEdd |8 bR|o o BIEEE L XA LA T AN A A
o T
iy Compiaion Py
OLLABORAIE.D
! = = e, =y
Nem Prgect Vizr

dHsrsicty [ 18 Foes | 8 Desgn Ut

=S =n Too 1% [T =
Fow:. [Complan = o 3
I — ) .
- Comple Deagn i
_frobas  Sribess
b Pt Pce b sl
b fasomeler Gererte progammeng feal Todnare: [cHones =l
b Ty Ay . T 3
B EDA Nefiat Witer o
B Frogam Devics Do Programeert I Rungas iudalion auomalicaly aftes canedaion
Todname: [<Hones =
[ e——] Fomet [ g
*[oype [Message E Ry

B. Block Design File (bdf format)
1) Choose New from File menu
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2) Highlight a new Block Diagram File
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3) Choose Save As
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4) Enter the file name of IntroFPGA and press Save
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5) Right click the mouse in the empty workspace
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6) Insert -> Symbol of and2 (2 input AND logic gate)
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7) Assign the name “LogicGatel” to and2 gat
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7) Repeat steps of 5) and 6) and insert a symbol and?2
Assign the name “LogicGate2” to and2
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8) Insert -> Symbol or2 (LogicGate3) and assign the name
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Quartus I - C:/My Documents/workshop/IntroFPGA - IntroFPGA

File Edit View Project Assignments Processing Tools Window Help
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9) Make wire connection and insert input/output pin to implement X=AB + CD. The bdf
workspace now has gates of AND and OR, and 4 input pins and 1 output pin. Then
make circuit connections.
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10) Change input and output terminal name to A, B, C, D, and X, respectively.
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C. Compiling the project
1) Choose Processing -> Start Compilation
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2) Message indicated no error
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D. Create a Vector Waveform File (vwf) to simulate the design
1) Choose File -> New -> Other Files ->Vector Waveform File -> OK
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3) Build the simulation file (vwf) with ending time of 20us and grid size of 1 us
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v B Fiter (Place & Route) 00.00.05)
v I _Assembler (Generate programming files)|00:00:03
~ B _Classic Timing Analysis 00:00:01
B EDA Netist Wrier

& Program Device (Open Programmer) | |

*| Type [Message

v
Hl d)  Info: Vector file IntroFPGA.vwi is saved in text Zormat. ¥ou can compress it into Compressed Vector Waveform File Zormat in order to reduce file size

@ Quartus T - C/My Documents/workshop/Introf PGA - IntroFPGA

File Edit View Project Assignments Processing Tools Window Help

[DE@@ &) & w0 o fmorpe A s @B | Tr e R S W80

SIE PP bl | 13 IntoFPGA. vt~
Entiy [Loge Cels [Dediated Logic
&y Cyclone I EP2CI5F672C6 | [
L roFPGA g JEXTICTC) ]
EIREEL) | pointer 2% Interval | 20830 Stat:|
po 109 2008 30pns 409
bixr ERLTT
]
¢ il 1
diyHienarchy s | ¥ Design Units
— CBassgidon
Fow: [Conptarn =] € Clock setings
Task - Time &
+ [ W Compie Design [00:00:13] @ Time periad:
v Analysia & Synihesis Poiod [T (=]
Fitar (Pace & Route)

RSANEN

W Clasec Tiing Anabaie Cancs)
» EDA Netlst Wiler

Uy Program Devics (Open Programmer)

]

Type_|Hea:

e
Tnfo: Vector file IntrofBGA.vWE i3 saved in text format. You can compress it into Compressed Vector Waveform File format in order to reduce file size

4) View -> Fit in Window

@ Quartus

File Edit View Project Assignments Processing Tools Window Help

/My Documents/workshop/IntroFPGA - IntroFPGA
Y O ™

I, |

osdd 8 e - mma ks E8e[0 > T us L 80 &le

| 16 InioFPGA vwi~

| 2] InoFPGA bat

Enity [ Logic Cells |Dedicated Logic.
By Cyclone |1 EPRCISFE72C6 | |
I 2 InroFFGA B ) |
I Master Time Bar. | F1175ns s Interval 1379ns Start
m =% o 400ns. 500ns. 600ns. 700ns.
- Name | 31180
& o
dh 1y
X8 L
A ZE
HE VE e
< [ama e e X
Ay Hierarchy | B Files | 7 Design Urits ¥ @ Cut Ctri+X
| E 5 Copy ctrisC
Flow: [Compilation Eeste) D
Delet Del ]
| e oo ° i
+ B P Cempie Desin Select Entire Waveform Interval i
v P inalysis & Syrthesis <« »
v P Fiter (Pace & Rote) = Insert Copied Nodes
v W hsserbler ~ -
v W Classic Timing Analysis |o0-0001] e ' : : : : :
P> EDA Netit Witer [ Zoom 3 Fitin Window CtrbeW
& Program Device (Open Programmer) | | P CurbeSpace
Zoom Out Ctrl+Shift+Space
Zoom...
Ll F—— D
= tgpe |vessaze

H| '3) Info: Vestor Tile IneroREGAwT 1 3ved in Cews Tomar. Fou oan compress i into Corpressed Veoror Wavefom File fomat in order to remuce Tile size
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i
Gdt e Projed Asmgomems Procemng Tacks

Help
L ERE DI e P L T R T A T
Y TR, T | B ot Pt |
'3 Loge Cales | Dedicated Loge
+ Cyelone I EPXCISFETICE.
oy [l Jom ]

ERE T

e

E32us Stat | End

o
T

128 25

T

024 52w 125 a8 [T 2w

O

6) Add inputs and outputs to the waveform (vwf)
Right click and select Insert Node or Bus

€8 Quartus -

7) Click N

File Edit View Project Assignments Processing Tools Window Help
B I I e e— | F - T A L A A
e 2% B InioFPGA b | 11 intioFPGA. vt |
Entity [Logic Cels [Dedicated Logc
By Cydlone I EP2CISFE7205 | |
- 3 hiFPGA g [t [om
= Master Time Bar.| 1750 o] | Pointer| 4512 Interval 43395 ns Statt
[y A vaem |22 128us 256us 3B 512us 64us 76Bus 8%us 10.24us 1152us 128us 14080
a @ Name | 373gns |[31.7750s
Lol
B L
A& cut Ctsx
HTE Copy CtrleC
e ' 1 )E @ - ,
yHierarchy [ B Fies | &F Design Urits YOG Delete Del
e — ‘_"I 8% 2L Insert »| InsertNode orBus..
ow:[Camplaton = Joom R Insert Waveform Divider
Tosk [ Tme & Insert Copied Nodes i
+ B W Compile Design 100:00:03) Show All Hidden Nodes | IR SR B R B i
v »_Analysis & Syrihesis [o0-00:01 | < " I T T T T O T T O
v P Fiter (Plzce & Route) 00:00:05|
v P Assembler (Generate programming fies) 00.00:02)
v P Classic Timing Analysis [o0-00:01 |
> EDA Netist Wrter | |
& Program Device (Open Programmer) | |

[ —— :

ode Finder

—=

File Edit View Project Processing Tools Window Help
IEEEY IO TN AEseee|orwron k@ @ ale|
L e InoFPGA bo | £ IntroFPGA. vt
Enity [ Logic Cells [Dedicated Logic
&y Cyclone Il EP2C35F672C6 | |
| [ -2 o i [l o 1) IntroFBGA wwf
= Master Time Bar:| EIRETS <[ | Pointer| 46512 Interval 433%ns Start
|T % vauem | P75 128us 256us 38us 5.12us 64us 763us 8% us 1024us 11.52us 12us
a @ Name | 371305 |BT175ms
i [
X &L
A&
HEE e
i B
EyHierarchy | B Fies | & Design Units 7 YR
. =i Insert Node or Bus s
Flow: [ Compiation |
Name: I3
Task Time ©
| ~/ B & Compile Design 00:-00.09) Type INFUT ~ Cancel
v W Analysis & Syrthesis 000001 e
Vatue ILevel =] [FodeFder. |
v P Fiter (Place & Route) 00:00:05 sueee Hode Finde.
"7 - Assembler (Generate. Radi [ascn
v P Classic Timing Analysis 000001 T
W EDA Netist Wrter
Il & Program Device (Open Programmer) Stattindex: [0
™ Display gray code count as binaiy count
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6) Choose Filter: Design Entry (All Name)
[@e

— -
File E3% View Project Assignments Processng Tooks Window Help
DBE@ & ' =@ v fwra ] MsEBO (D > [VOk @[B4 0|
T X imoreasa | R IntoFPGA vt |
Eaty TiogoCels
Crokne It EPICIFETCE | |
' - offGA Jg om o jom R IntrofOGA
] Mastes Tine Bar| ERT Y || Porver | 4512 Intervat | @B Stast|
hA®% | (£ 2% EETS 512w Sdwm 768us B%us 1024us NR2u 125
Name [ Yhe |
Node Finder T, =)
Nomed: [ =] Fec [Pt =] _ Cuomas | U Q o |
Lok it =] 1 ncude subertives 5 Carcel
Nodes Fourd
[ [assigeents [ Hame. Thssigmenss [
A Unassigned |
s Unassiged |
lwc Unsssignad |
v B Avayas § Sythesa lwoo| « >0 Unsssigned |
VBB fiter (Place b Foe) 000005] = ox Unassgnd | {
v @D Assembier Gerente programming fles) 00 00.02) =
V6P Oassc Tmng Archves 000001 |
i )
|
el
ALl Unused Pins serting has not bes
£ vas successful. 0 srzors, & warad| W
“ i 0 “ 0 v
Intor Running Quartus 11 Assesbler i

7) Select inputs/outputs names from Node Finder screen to the right side and click OK

File Edit View Project Assignments Processing Tools Window Help

@& e |

DEE@ & ¢ =@ o o oo s @w e Tr X uB| b

InkioFPGA bef

| 1) IntroFPGA. vwf

Entiy [Logic Cels [ Dedicated Logic
Ay Cyclone I EP2G35F6726
2, rinfPGA fg) [fo ho
Master Time Bar:| ERET || Pairter E12ns Intervat 43Fns Stan
b 12808 256us 388w 513us 64 75pus 856us 0w 1152
N Valve at ; ; i ? d ; f 3 ;
ame | 31330 | pT178Ts
Node Finder
Named: [ =] Fiter: [Pis: o - Custarize, Lit oK,
- , | =1 e i | |
Ay Hierarchy | B Fies | g9 Design Unis Look in: [ v].] T Include subertites ﬂl ﬂl
Mades Found Selected Nodes:
Fen: [Conplain - Name Assignments Name: [ essignments |
- B IntoFPGALA, Unassigred |
TaskS £ IniGFPGAE Unassigned |
+/ @ P Comple Design 5 IncFPGAC Unassigred |
v P Aralysis & Syrthess B> ntiaFPGAD Unassigred |
v P Fiter (lace & Route) DD lInoFPGAN Unassigned
v B Assembler (Generate programming fles)
v B Classic Tring Anslysi
P EDANelist Witer
> Program Device (Open Programmer)
 —— D
* Type  |Message
al Warning: The Reserve ALL Unused Fins secting has mot bee
3y Info: Quartus II Fitter was successful. 0 errors, 4 warnd)|
i1} Tnfo: g 1 v [ —— r
A 1

Fie Edt View Project Assignments Processing Tools Windew Help

DEH@ & 4BE o wre | HLEEE T 20 wH(E &0 &0
_ IrtsafPGA. b | 15 IntioFPEA vl
Erety [Loge Gl [ Decicsted Lo
& Croore I EPCIFETE |
& morPoh By 10 ()
&
Ik A%
N = ]
L
B8
MEE
A E
wEw Select Entire Waveform Interval
R
T 24 Value 3 Stretch or Compress Waveform Interval. CrrlelteS
Grouping. » Offset Waveform Interval... CuleAltsO
Display Format »| Uniniiskzed (1) CtrleAtel
Nodes »| Forcing Unknown (1) CttoaiteX
= \
~ D0 Group and Bus Bit Order » et Enil
S Forcing High (1) Curleitel
Locate b High Impedance (2} CuleAlteZ
Zoom »| ek Unknown W) Ctrie AW
" ‘Weak Low (L) Carl+Alts L
- Weak High (H) CirleAlteH
Dont Care (D€) CtrieAieD
. i ' vt Cule el
Count Value... Ctte Aty
o T i
f Warning: The Reserve ALl Unused Pins secting has oo been specified, and will default to 'As output
m"j Fitter wes successful, 0 errors, 4 warnings Ctrle AlteB
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i Guartus 1 -Gty InkrofPG: =

[Fie bdn View Propet Assguments Processng Took Window Help
LG IERL T l—_|mmm HABEG T r 0Bk S ® a0
e oot R imerpaab | 18 IntioFPGA vwi*
Cells [Dedcatec
Ay Cychone |- EPCISFETCE
L3 worra gy [im fom R IntroFOGA vt
Mastes Tine Bar N7 <[] Porter; =TT triervat | [z Stat
& A% e | PP 128us 256us 38 517 64us 788us 855us 103808 N52w
8o MName | 394gog |F11750s
Y 0 ]
_ Cal B AD
AT ¢ |
i M ENE (@3] o iy
l L E O (2R x v | e e
« latiad E BIENE . -
e e
= Star time: [0 P
= £
[ [Compiaton - i Endlime. 200 P
j e iy —
+ B ¥ Compie Desgn 0000 P
v — P Anaiysis & Syrthesis 00:00-01 L »
W B e Pace § Fouts) 0000 = - - - =]
| A LEd NN @ Tine peicd
P Gl Teneg s oeocor] M - fi B TR
‘.“ - EA T RS R i Paioe 2 |EE]
& Progran Dence (Open Progammer E . B [T ) |
o EEE byt [T

9) nghllght the input B, choose Edit =>Value >Clock Enter a period of 4ps, press OK
10) Highlight the input C, choose Edit =>Value =>Clock. Enter a period of 8us, press Ok
11) Highlight the input D, choose Edit =>Value =>Clock. Enter a period of 16ps,

press Ok
iz) Choose File => Save as IntroFPGA.vwf file

He (e View Project Avigements frocmung Took Windew bl

DEEP & % ®@ |0 o Hr7@VS D »Wn O &S ¥ &0
| Praect Nawigator B orroasa | R o PGA vwt* |
| [ oo oot
& G s | |
| [T veorocn 25 )
@ [ T P e | e St [ £ Wow
5 A% e [ B e e She G ge e e e me  Wge  ewe  wee vwe
e tme | W |G
. @i x %o
oAl O 5 S
B2 wr| A0
A&E[BI] o a0
ME & £ x AX
¢ B
Dttwacty (BT g G .
= 3 Swvern: [ worbon T o] cmoE
‘E: z Mame. = Onte modfed Type
Ve WS de VDTN ekl
v Ee L incrementsldb 12 100M  Fieolder |
i EF B Qs 21295 Quatusd
=3 |
20 23 o
B =
B
A | i
Comoute
e - 000 |
oot
= |
| Pt o i cempar ariving grewna
k e .
e rame ’ﬁmrm Swe
x o
Save aa type. |Vector Wiavefom Fie (vwf) Cancel
7 Add a0 cumart promet 4

E. Perform a simulation of the X-output
1) Choose Processing => Start Simulation
e —

DEE@ S|t mE || Dowie it BOSIT(> (B0 k(OB 20|
ProjectMavigater —————————————— > Stant Complation Crlel | 1 IntioFPGA ywi |

Cyclone i EP2CI5F67206

| B
g ofor 35 0 o

® compilstion Beport Lok e RS ] poec 50w Irtorvat | EEM Stat: Ops CEnd 204

Start Compdstion and Simulstion CirlShiftK | 128 256 388 512u 4w 760us 85us 10260 1182w 128w MQBus 1536w 16 URw
wrmwmuﬁ e [3118m

smnmnm »
& simulation Report CuteshifteR 0
B Compiles Tool [ A8
5 Simulator Tool
1) Classic Timing Analyzer Tool
M@m_ ¢4 BowerPlay Power Anslyzer Tool

frode—————————————— ¥ Ssﬂhul/nﬂod
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2) Show the results of the simulation for the Boolean equation X = AB+CD

‘W‘:“m“ '-_'"i-_ N NN W S

L I dmrsees e % wle
—_—— E D irroaba @ e | & Semistion Fepon - Simubston Wavsforms
Ew) Jiogse Cots | Decicated
&y Cyclone I EPXCISFETE. .
- rren g o m i e —

dyHienarchy [ Fies | & Design Uit
T

F. Programming the FPGA using the Altera DE2 Programmer Board (hardware

configuration)

1) Connect SWO0, SW1, SW2, SW3 and LEDGO to the associated pin number

Input Switch

Output LED Bank 1

Switch Number

Pin Number

LED Number

Pin Number

SWO (A)

PIN_N25

LEDGO (X)

PIN_AE22

SW1 (B)

PIN_N26

SW2 (C)

PIN_P25

SW3 (D)

PIN_AE14

2) Assign specific pin numbers in the IntroFPGA for connecting to the DE2 board

Choose Assignment -> Pins from the assignment Editor screen

&2 Quartus I - C/My Du(umen\slw;rbhnpllntroFPGArlmmFPGA - [Pin Planner] - o D
File Edit View Processing Tools Window
Groups: ” -
= Named =] Top View - Wire Bond
NN Cyclone Il - EP2C35F672C6
E f E -
=S Wislelelvielat Ay e
= et - BEoYa00 6 Q oo ea@@@@ﬁ@vee .
= ROBVEAVAADYVBAASVADVAYVOLUEE «
2 e @QAOOA X%OA@@ Qe
= ___ CASAGCOVVOD0ACADYEE0S
g SOEOCHANCADCTADCADOGE - E=4
= . OOEEVOCO08E -
B # B AY00000 i @@@Vﬁ@oe .
= . 80% AYATAYAYS Eleleielsletoin B
= ~ [ og VYW ASVO X AD DER -
o S OVOAVVVVY QO\/O{\/}— on ¢
& B - 500 SARAVAGAGEY G000 -
& TAGOAVOOL DD, WVADBOOASHOOM -
WO OALD, {ataaw)
> } ‘ ACOEADDAADGADDAGD :
a SOBVAVOADGDY Y @@%D\JG o0 B
@ X DOOVAYY VAVAD ’
. TAGED 5 e@vg fals]
5y “DOOOA VAVMXA@ {51a3 @@0
v “RREOVOOADDCOANDOAD B
. e Voo m\ioeoveAG)@@@@e
= - A o
<[] D =
Named: [§ -]« Edit: 3| | ‘ Fiter: | Pins: all |
Node Name Direction Location 1/0 Bank [ VREF Group 1/O Standard Reserve: d
1 » A tnput FIN_N25 5 B5_N1 3.3-VLVTTL (default)
2 » B Input: PIN_N25 5 B5_N1 3.3V LVTTL (default)
3 [ | Input PIN_P25 6 B6_NO 3.3-V LVTTL (default)
4 [ Input PIN_AE14 7 B7_N1 3.3V LVTTL (defauit)
5 2 X [Qutput. PIN_AE22 7 7m0 3.3V LVTTL (default)
6 <<new nodex> [

3) Choose File -> Save Project.
The bdf file showing the pin assignments
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@ oums -y e i -~ e T . T T -
—
File Edit View Project Processing Tools Window Help
DEE@ |8+ 200  |morre IR @86 0> v voln @8|a e |
Project Navigator ——————————————— 1~ X £ |nuoFPGA.bdf I'@ et
Entity [Logic Cells [ Dedicated Logic
iy Cydlone I EF2C35F672C6 |
2 IniroFPGA I [Ty i) Subscribe to Altera®  Subscribe to Altera®  Subscribe to Altera®  Subscribe to Altera®  Subscribe
Enewsletters Enewsletters Enewsletters Enewsletters Enewslette
LogicGate1 N
5 Ry H
a4 P
L8 {Logqegaten PIN_AEZ2Z
« v ™
yHierarchy | B Files | ¢ Design Urits =
h < :
a©n PIN_AE14 ihagicGateZ, .. [
Flow: [Compilation p— IR
Task & oo
© W Com NN
>
>
>
>
il P EDA Netlst Witer
I & Program Device (Open Programmer)
It

4) Choose Processing -> Compilation.

After the compilation is successful, press OK
€ uores1 by Decomerggiororiirion GG L NN

|[Fite Edit View Project Assignments [Processing] Tools Window Help

|JDD°EE‘§H€%E|n@§tanproc===mg Ctrl+Shift+C P@@WP’«"@M&HM@\@\M\
|| Profect Navigator ———————| »- |ENYERTT Ctrl+L I | B imrofPoe et @
Enity [Logic Col| B3} Analyze Current File
| [ & Cychone I EP2CI5FETCE. | start R
2 riofPea fg i) Update Miemary Intislization Fil Subscribe to Altera®  Subscribe to Altera® ~ Subscribe to Altera®  Subscribe to Altera®  Subscribe to Altera®
Update Memory Initialization File Enewsletters Enewsletters Enewsletters Enewsletters Enewsletters
& Compilation Report Ctrl+R

Start Compilation and Simulation Ctrl Shift+K

Generate Functional Simulation Netlist

P Start Simulation Ctrl+1 P SRR - {anDz”
Simulation Debug »
| & Simulation Report CtrleShift+R R
5 Compiler Tool o T T o ) MHBIFE = T o
Loqcoates. . PIN_AE22

| & Simulator Tool
¢l 3 Classic Timing Analyzer Tool
&y Hierarchy [ B Fies | & Design Unts £ PowerPlay Power Analyzer Tool

W SSN Analyzer Tool

Ta

Fow: [Conpiaton M=

| Task [ | Time & oo
EILEE NN

P EDA Netlist Writer
| & Program Device (Open Programmer)

5) JTAP Programing and Configuring the FPGA Device.The FPGA device must be
programmed and configured to implement the designed circuit.
i) Flip the RUN/PROG switch of DE2 development into the RUN position (default)
i) Choose Tools-> Programmer.

@ Quarts T o fchor
Fie Edit View Project Assgnments Processing
|D'5"Hﬁ~5 R0 oo st 'F:»v«'&@:@@&n
| n::mvmw Tiogs Cate [Dadcasd L::::oh m:mng i empiler | B rmorrimt
| [ &y Cycione Il EP2CISFETCE IR Launch Design Space Explorer
8 noreeh ig 10 00 | ety TimeQuest Timing Analyzes

Advisors 0

@ Chip Plannes (Floorplan and Chip Edter)
& Design Patition Planner
Netist Yiewess v

(B SignalTop B Logic Agalyeer
e In-System Memarg Cantent Editor
B Logic Analyzes Interface Editor

) in-System Sources and Probes Edtor

:

A A ) W —— .
Tagks. B o N o N N N Logelame? 1T
Row. [Comoiaton “, MegaWizard Plug-In Manager... . ool Sl ol . .

T 23! SOPC Builder

0| Tel Scripts.

1 Customize...
| Options...
E T License Setup...
I EDA Vet Virer
@ :ugm D,v: @':,. rogmmmnr Customize Block Editor...
. Optiens for Black Editor...
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iii) Click Hardware Setup -> Select Add Hardware
iv) Choose USB-Blaster (Hardware type) press Close

5] Quartus I - My -

oE, =
[Fle Edt Processng Tools Window

&, Hurdware Seip..| | No Herdware: Mode [ITAG =] Frogem 0x

=

P st | |Fe [oevie Creckum  [Usmcote | B2 T wany [ Bork [ evamie | %200 | e [ ([

s TGRSl EPITFETE UGS PRI M O - O O O O

i Auta Detect

¥ Debie Hardware Setup =
b Ak Fie Hardware Senngs | STAG Sestngs |

58 Change i e i T
B SaveFie

= Curenily selected hardware: Mo Hadware =]
fc Device

Avalatle haidware e
i ) Hardwar= Server Port dd Hardware

Loca UsBD

$ Dour

v) Make sure Program/Configure check box
Quartus IT - C/My Documents/workshop/IntroFPGA - IntrofPGA -

Fle Edt Procesng Toos Window

2. Hasdmere Seup, | [US8-Blaster [USE-0) Mode [TAG +| Poges 0%
<
Mo [ B e A R A S e T B

o PGA 5ol EPALIF6T2 CFB73  FFFFFFIT ] ] T

6) Download the embedded system design to Altera EP2C35F672C6. Press Start for
starting the programming process until progress 100%
T |

File Edit View Project Assignments Processing Tools Window Help

[DEE@ (8] ee ocmre R FRE| 0> 2 n[oD|[5 @B 20
** ) InkoFPGA.bdf | 1) IntoFPGA vt
[ Logic Cels [Dedicated Logic

Entty
by Cycone Il EF2CI5F67206 | |

2 riofPGA fg [t oo subscribe to Altera®  Subscribe to Altera®  Subscribe to Altera®  Subscribe to Altera®  Subscribe to Altet
al = 'u} Enewcletters Enewcletters Enewclatters Enewclattors Enewclattors
IntroFPGA.bdf
=
1) Quartus I - €:/My Documents/workshop/IntroFPGA - IntroFPGA - [IntroFPGA.cdf] ==

File Edit Processing Tools Window |

2 Hoae S, | [ TSTase 5541 ot 735 5] R

[ Enable reaktime ISP to allow background programming (for MAX I devices)

B IR | |Fie |Devu:a |Ehatksum Usercods E’;?ESQ Verty | Benkc | Evamine | SeS | grage | 1SR |
4 #or TnIGFPGA sof EF2CIFET2 O0ZFEETS  FRFFFFFE O O O 0O O
Tod| | b Auto Detest
A

K Delete
[| 5 Add File
|| B Change File
b Save File.
8 Add Device.
4 up
¥ Down
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G. Test the download design (X = AB + CD ) to the FPGA chip by combinations of input

levels and observation of the output responds

Truth Table for Testing the FPGA program for X= AB+CD

A (SW0) B (SW1) C (SW2) D (SW3) X(LED)

0 (DOWN) |0 (DOWN) |0(DOWN) |0 (DOWN) |0 (Led off)
0 (DOWN) | 0 (DOWN) | 0 (DOWN) | 1 (DOWN) | 0 (Led off)
0 (DOWN) |0 (DOWN) |1 (UP) 0 (DOWN) | 0 (Led off)
0 (DOWN) | 0 (DOWN) | 1 (UP) 1(UP) 1 (Led on)
0 (DOWN) |1 (UP) 0 (DOWN) | 0 (DOWN) |0 (Led off)
0 (DOWN) | 1 (UP) 0 (DOWN) |1 (UP) 0 (Led off)
0 (DOWN) |1 (UP) 1 (UP) 0 (DOWN) | 0 (Led off)
0 (DOWN) |1 (UP) 1 (UP) 1 (UP) 1 (led on)
1 (UP) 0 (DOWN) | 0(DOWN) | 0(DOWN) | 0 (Led off)
1(UP) 0 (DOWN) | 0(DOWN) |1 (UP) 0 (Led off)
1 (UP) 0 (DOWN) | 1 (UP) 0 (DOWN) | 0 (Led off)
1 (UP) 0 (DOWN) | 1(UP) 1 (UP) 1 (Led on)
1 (UP) 1 (UP) 0 (DOWN) |0 (DOWN) |1 (Led on)
1 (UP) 1 (UP) 0 (DOWN) | 1 (UP) 1 (Led on)
1 (UP) 1 (UP) 1 (UP) 0 (DOWN) |1 (Led on)
1 (UP) 1 (UP) 1 (UP) 1(UP) 1 (Led on)

H. Your turn — Practice
Follow the steps to update your design by adding four buffers. Design and test the logic
to implement the circuit shown in the figure bellow.

) Work

on the design entry IntroFPGA.bdf and insert buffers to your design

B

B @eqragsao00>=|4

cmnn!-, ——
TEL L1 P
g ITHELZSE
3 citg
%

Eo
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2) Insert output pins and update the names of outputs: LEDRO, LEDR1, LEDR2, and

LEDRS3

File Edit View Project Assignments Processing

Tools Window Help

Dedad & ) IntroFPGA S rEe G TR A e AR R |
Project Navigator * > £ IntoFPGA.bdF ‘
Entity [ Logic Cells [ Dedicated Logic
Ay Cyclone Il: EP2CI5FE72C6
- 3 IntroFPGA. g m LIO] ] ) IntroFPGA baf*
=]
R
A
Eng
o
"1
!
Bl e e i
: S ]
TE . i
Lot N T
& FIN_AETE
=
< [om] v “
" diyHierarchy [ B Fiks | 67 Design Units
Tasks S x
Flow: ~[Compilstion =

3)
4)

associated FPGA pins.

Save your file and Compile your design and see if any error
Update Pin Planner and configuration to make connection between logic pins to

File
b@Ldda &

Edit View Project

Assignments Processing

Tools Window Help

3l IntroFPGA VB

v tpdh k&8 A e

Project Navigato

¥ Quartus I - C/My Documents/workshop/IntroFPGA - IntroFPGA - [Pin Planner]

Enity
& Cyckone i
2 itror]

File Edit View Processing

Groups

Named: [ -

Node Name

Tools  Window

Oi

Top View - Wire Bond
Cyclone Il - EP2C35F672C6

<cnew noc>> o == EER
COOTOOOAYIOVATSTOT
OVEOEE A DA
6 oo e@@@ 0ACYVOE
AASYADYAVBEOOD) -
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Node Name Direction Location L/O Bank VREF Group 1/0 Standard Reserved
1 w A |Input. PIN_N25 5 BS_N1 13,3V LVTTL (defauit)
2 » B [Input PIN_N26 5 BS_N1 13.3-V LVTTL (defauit)
3 » C [Input PIN_P25 6 B&_NO 13.3-V LVITL (defauit)
B [) [tnput PIN_AE 14 7 B7_NL 3.3V LVITL (defauit)
5|9 wmw output PN AE2S 7 7.0 5.3 LV, (defat)
6 &  LEDR1 |Output. PIN_AF23 7 B7_NO 3.3V LVITL (defauit)
7 4 LEDR2 |Output. PIN_AB21 7 B7_NO |3.3-V LVTTL (defauit)
B © LEDR3 [Output. 7 B7_NO 3.3V LVITL (defauit)
Bl =& X |Qutput PIN_AE22 7 B7_NO 3.3V LVTTL (default)
10 <<newnode> > |

5)
6)
7)

Compile your design with FPGA device hardware
Download the design to FPGA IC. Observe the output LEDs and inputs Switches
Explore different led lights by your own.
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Signal Name FPGA Pin No. Description
SWIO0] PIN_N25 Toggle Switch[0]
SWI[1] PIN_N26 Toggle Switch[1]
SWI2] PIN_P25 Toggle Switch[2]
SWI3] PIN_AE14 Toggle Switch[3]
SWI4] PIN_AF14 Toggle Switch[4]
SWI5] PIN_AD13 Toggle Switch[5]
SWI8] PIN_AC13 Toggle Switch[6]
SWI7] PIN_C13 Toggle Switch[7]
SWI8] PIN_B13 Toggle Switch[8]
SWI9] PIN_A13 Toggle Switch[9]
SWI[10] PIN_N1 Toggle Switch[10]
SWI11] PIN_P1 Toggle Switch[11]
SWI[12] PIN_P2 Toggle Switch[12]
SW[13] PIN_T7 Toggle Switch[13]
SW[14] PIN_U3 Toggle Switch[14]
SWI[15] PIN_U4 Toggle Switch[15]
SWI18] PIN_V1 Toggle Switch[18]
SWI[17] PIN_V2 Toggle Switch[17]
LEDRI0] PIN_AE23 LED Red[0]
LEDRI1] PIN_AF23 LED Red[1]
LEDR[2] PIN_AB21 LED Red[2]
LEDR[3] PIN_AC22 LED Red[3]
LEDR[4] PIN_AD22 LED Red[4]
LEDR[5] PIN_AD23 LED Red[5]
LEDR[B] PIN_AD21 LED Red[8]
LEDR[7] PIN_AC21 LED Red[7]
LEDR[8] PIN_AA14 LED Red[8]
LEDR[9] PIN_Y13 LED Red[2]

LEDR[10] PIN_AA13 LED Red[10]
LEDR[11] PIN_AC14 LED Red[11]
LEDR[12] PIN_AD15 LED Red[12]
LEDR[13] PIN_AE15 LED Red[13]
LEDR[14] PIN_AF13 LED Red[14]
LEDR[15] PIN_AE13 LED Red[15]
LEDR[16] PIN_AE12 LED Red[16]
LEDR[17] PIN_AD12 LED Red[17]
LEDG[0] PIN_AE22 LED Greenl[0]
LEDG[1] PIN_AF22 LED Green[1]
LEDG[2] PIN_W19 LED Green[2]
LEDG[3] PIN_V18 LED Green[3]
LEDG[4] PIN_U18 LED Green[4]
LEDG[5] PIN_U17 LED Green[5]
LEDG[6] PIN_AAZ20 LED Greenl[6]
LEDG[7] PIN_Y18 LED Green[7]
LEDG[8] PIN_Y12 LED Greenl[8]
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