OpenLab Pioneers!

You must be logged in to reply to this topic.

  • Author
    Posts
  • #12357

    Daniel Alter
    Participant

    Hello All,

    I place my setting as admin. must moderate first post there after it would be OK without moderation. Every post seems to still end up in moderation even if previous post was approved by same authors.

    Also, when I go ahead and post or comment it too shows up in moderation????????

    Thanks,
    Danny

    #14141

    Bree Zuckerman
    Participant

    Hi Danny,

    Under Settings > Discussion, do you have the following box checked: “Comment author must have a previously approved comment”? The other one, “An administrator must always approve the comment” should not be checked.

    The only other thing I can think of is that students might be trying to post while they’re not logged in? In this case the system would not recognize them and thus ask you to approve their comments. You can also control this under the discussion settings: There’s a checkbox that require users to be registered and logged in to comment.

    But, let me know if this doesn’t solve the problem.

    Thanks!
    Bree

    #14145

    Daniel Alter
    Participant

    Hello Bree,

    That is the setting I had all along. Similar to Jonas every post and reply I make goes to mediation first. Certainly the comments I author should need approval. :)

    Danny

    #14147

    Prof. Paul King
    Participant

    Hi Bree and Daniel,

    I have the same settings in my admin and I find all comments require moderation including my own. Several times I have posted a comment only to find later I had to moderate myself.

    Paul

    #14150

    Bree Zuckerman
    Participant

    Thanks Danny and Paul.

    I’ll check this out and let you know what’s going on. It sounds like it might be a bug.

    Best,
    Bree

    #14151

    Bree Zuckerman
    Participant

    Hi Danny, Paul and Jonas,

    Scott, Elizabeth and I tested this out and weren’t able to reproduce the problem. Would you mind giving me administrative privileges on your site, so I could do some more troubleshooting? To do so, you would have to add me as a user. (Users > Add New). I’m registered on OpenLab with my GC email, which is: bzuckerman@gc.cuny.edu. Then, choose administrator as the role.

    Also, Danny, do you mind if I post a comment to your site so that I can try to see what’s happening with the page jumping?

    Thanks!
    Bree

    #14155

    Bree Zuckerman
    Participant

    Hi everyone,

    Jonas added me as an administrator and I was able to comment without needing to approve my comment. So, this just adds to the mystery! Were you all having this problem only on your course site, or also on the course group?

    In any case, my laptop battery is about to die, so I’ll check back in later. Can you let me know if this problem continues? Perhaps it was just a temporary permissions issue that was fixed by the developers?

    Thanks!
    Bree

    #14156

    Daniel Alter
    Participant

    Certainly Bree, Feel Free to comment. Maybe start a new discussion or blog??????
    You were added as administrator for my site. Have fun….
    Danny

    #14164

    Bree Zuckerman
    Participant

    Hi all,

    I tested on both Danny and Jonas’s sites, as both an administrator and with a test account and was not able to reproduce the problem. The only time I had to approve comments from the test account was after I had deleted them, which seems to purge the previous approval.

    However, when I looked at the comments admin page on both sites I noticed that students had commented when they weren’t logged in. (Those who are logged in will have the URL for their OpenLab profile listed along with their email). So, this may have contributed to some of the extra approvals. But, it also might be that this was a permissions problem that was fixed, because I couldn’t reproduce the problem of having to moderate your own administrator comments.

    One last thing, Danny, I noticed that you might have some stealth spam on your sticky post. “San Antonio Family Dentistry” has posted something about restorative dentistry, which is probably meant to draw traffic to their website.

    Anyway, please let us know if this problem with the comment moderation continues.

    Thanks!
    Bree

    #14168

    Daniel Alter
    Participant

    Thank you Bree, I noticed you were very busy there for a while. :) I wanted to ask you to run a test through one more scenario which might illustrate what we are seeing. Being that you have both test student and admin; might you start a discussion or blog. with the admin, then comment as a student and then reply to that comment as the admin again. That’s what played out earlier where I started a blog. an/or discussion then received comments from students which in turn I replied to that comment. That’s when I received moderation needed for all..

    So, if you can please try that and hopefully you can recreate what happened earlier.

    Also, I am concerned about the San Antonio Family Dentistry post. Should I delete it? How do you know it has a stealth spam attached to it? and how can I prevent anything like that from happening in the future?

    Thank you so much for all your help,

    Danny

    #14170

    Bree Zuckerman
    Participant

    Hi Danny, I just tested that scenario and got the same results–I had to moderate the initial student comment but nothing else.

    Regarding the “stealth spam,” it’s not from a spam bot; it is an actual comment posted by a real person. But, while it appears to be a genuine comment related to the content of your post, it is designed to generate traffic to a website (in this case, a dentist in San Antonio). You shouldn’t get any more of these since you have to approve the first post by any user. It might have gotten approved by accident, or perhaps snuck in before you changed the approval settings. I would delete it, but it’s up to you.

    Best,
    Bree

    #14174

    Jody R. Rosen
    Participant

    Bree, did you mention here that comments with more than two links need moderation unless the settings are changed? I don’t know if that was part of the problem, but it’s worth noting so that if comments tend to have a few links, we can increase the number allowed before sending the comment into moderation.

    jrr

    #14180

    Bree Zuckerman
    Participant

    Hi Jody, I think that was Elizabeth who brought that up, in another email. But yes, that’s a good point about the links. Those settings are on the same page as the other discussion settings.
    Thanks,
    Bree

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.