
Create ruler guides

Ruler guides are different from grids in that they can be positioned freely
on a page or on a pasteboard. You can create two kinds of ruler guides:
page guides, which appear only on the page on which you create them, or
spread guides, which span all pages and the pasteboard of a multiple-page
spread. You can drag any ruler guide to the pasteboard. A ruler guide is
displayed or hidden with the layer on which it was created.

New ruler guides always appear on the target spread. For example, if
several spreads are visible in the document window and you drag a new
guide into the window, the new guide becomes visible only on the target
spread.

Guides in the document window

A. Spread guide B. Page guide 

Create a ruler guide

Make sure that both rulers and guides are visible, make sure the
correct spread is targeted, and view the document in Normal View
mode, not Preview mode.
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A vertical and horizontal guide created concurrently

Note: To reposition a ruler guide numerically, select the guide and enter

If the document contains multiple layers, click a layer name in the
Layers panel to target the layer.
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Do one of the following:

To create a page guide, position the pointer inside a horizontal or
vertical ruler and then drag to the desired location on the target
spread. If you drop the guide onto the pasteboard, it spans the
pasteboard and spread; it will act as a page guide if you later drag
it onto a page.

To create a spread guide, drag from the horizontal or vertical
ruler, keeping the pointer in the pasteboard but positioning the
guide at the desired location on the target spread.

To toggle between horizontal and vertical guides, select the
guide and hold down Alt (Windows) or Option (Mac OS).

To create a spread guide when the pasteboard is not visible (for
example, when you’ve zoomed in), press Ctrl (Windows) or
Command (Mac OS) as you drag from the horizontal or vertical
ruler to the target spread.

To create a spread guide without dragging, double-click a specific
position on the horizontal or vertical ruler. If you want to snap
the guide to the nearest tick mark, hold down the Shift key when
you double-click the ruler.

To create vertical and horizontal guides simultaneously, press Ctrl
(Windows) or Command (Mac OS) as you drag from the target
spread’s ruler intersection to the desired location.
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values for X and Y in the Control panel.

Create a set of evenly spaced page guides

If the document contains multiple layers, click a layer name in the
Layers panel to target the layer.
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Choose Layout > Create Guides.2

For Number, type a value to specify the number of rows or columns
you want to create.
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For Gutter, type a value to specify the spacing between rows or
columns. Start with a low value, such as 1 pica; large gutters leave
little space for columns.
Columns created with the Create Guides command are not the same
as those created with the Layout > Margins And Columns command.
For example, columns created using Create Guides cannot control
text flow when a text file is placed. Use the Margins And Columns
command to create major column divisions appropriate for autoflow
text, and use the Create Guides command to create column grids and
other layout aids.
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For Fit Guides To, click Margins to create the guides within the page
margins, or click Page to create the guides within the page edges.

Ruler guides evenly spaced within page margins
(left) and page edges (right)
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To delete any existing guides (including guides on locked or hidden
layers), select Remove Existing Ruler Guides.
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If you like, select Preview to see the effect of your settings on the
page, and then click OK.
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Note: The Create Guides command can create page guides only; it cannot
create spread guides.

Note: To space existing guides a uniform distance apart, select the guides
(by dragging or pressing Shift as you click with the mouse). Then, select
Use Spacing from the Control panel, type the space value in the text box,
and press Enter or Return to confirm. Click either Distribute Horizontal
Centers  or Distribute Vertical Centers  to the left of the Use Spacing
option.

Show or hide guides

To show or hide all margin, column, and ruler guides, choose View >
Grids & Guides > Show/Hide Guides.

To show or hide ruler guides on one layer only without changing the
visibility of the layer’s objects, double-click the layer name in the
Layers panel, select or deselect Show Guides, and then click OK.

To show or hide guides and all other non-printing elements, click the
Preview Mode icon  at the bottom of the Toolbox.

Work with ruler guides

You can change the attributes of individual ruler guides, and you can move,
cut, copy, paste, or delete multiple ruler guides simultaneously. Cut or
copied ruler guides can be pasted to other pages or documents, but not to
other programs. To change attributes of specific guides, you must select the
guides you want to change. When no guides are selected, the Ruler Guides
command sets the defaults for new guides only.

Select ruler guides

Unselected ruler guides appear light blue by default. Selected ruler guides
are highlighted in their layer color. When a guide is selected, the Reference
Point icon in the Control panel changes to  or , representing the
selected guide.

To select a single ruler guide, use the Selection tool  or the Direct
Selection tool  and click the guide to highlight it in its layer color.

Note: If you can’t select a ruler guide and the View > Grids & Guides >
Lock Guides command is already deselected, the guide might be on that
page’s master, or on a layer where guides are locked.



To select multiple ruler guides, hold down Shift as you click guides
using the Selection or Direct Selection tool. You can also drag over
multiple guides, as long as the selection marquee doesn’t touch or
enclose any other object.

To select all ruler guides on the target spread, press Ctrl+Alt+G
(Windows) or Command+Option+G (Mac OS).

Move ruler guides

Using Selection tool  or the Direct Selection tool , do any of
the following:

To move a ruler guide, drag it.

To move multiple ruler guides, shift-select the guides you
want to move, and then drag them.

Move selected guides just as you would any other selected
object, including nudging with the arrow keys and using the
Control or Transform panels.

To make a guide snap to a ruler tick mark, press Shift as you
drag it. Or select the guide, press and hold down the Shift
key, and then click the mouse button.

To move a spread guide, drag the part of the guide that’s on
the pasteboard, or press Ctrl (Windows) or Command
(Mac OS) as you drag the guide from within the page.

To move guides to another page or document, select one or
more guides, choose Edit > Copy or Edit > Cut, go to another
page, and then choose Edit > Paste. If you’re pasting onto a
page of the same size and orientation as the guides’ original
page, the guides appear in the same position.

Note: The Paste Remembers Layers option affects the layer on which
pasted guides appear.

Delete ruler guides

To delete individual guides, select one or more ruler guides and then
press Delete. (You can also drag ruler guides and drop them on a ruler
to delete them.)

To delete all ruler guides on the target spread, right-click (Windows) or
Ctrl-click (Mac OS) a selected guide or ruler, and choose Delete All
Guides On Spread.



If you cannot delete a guide, it may be locked, it may be on a master page,
or it may be on a locked layer.

Customize ruler guides

Note: You can set the current magnification as the view threshold for new
ruler guides by pressing Alt (Windows) or Option (Mac OS) as you drag the
ruler guides you’ve selected.

Lock or unlock ruler guides

To lock or unlock all ruler guides, choose View > Grids & Guides > Lock
Guides to select or deselect the menu command.

To lock or unlock ruler guides on one layer only, without changing the
visibility of the layer’s objects, double-click the layer name in the
Layers panel, select or deselect Lock Guides, and then click OK.

Change ruler guide stacking order

By default, ruler guides appear in front of all other guides and objects.
However, some ruler guides may block your view of such objects as lines
with narrow stroke widths. You can change the Guides in Back preference
to display ruler guides in front of or behind all other objects. However,
regardless of the Guides in Back setting, objects and ruler guides are
always in front of margin and column guides. Also, although putting guides
on different layers organizes them structurally, it does not affect their visual
stacking order—the Guides in Back preference stacks all ruler guides as a
single set in relation to all page objects.

Do one of the following:

To change options for one or more existing ruler guides, select
those ruler guides.

To set default options for new ruler guides, deselect all guides by
clicking in an empty area.
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Choose Layout > Ruler Guides.2

For View Threshold, specify the magnification below which ruler
guides do not appear. This prevents ruler guides from appearing too
close together at lower magnifications.
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For Color, choose a color or choose Custom to specify a custom color
in the system color picker. Then click OK.
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Default stacking order

A. Ruler guides B. Page objects C. Margin and column guides D. Page 

Snap objects to guides and grids

To precisely align objects to guides, use the Snap To Guides and Snap To
Document Grid commands. Object edges will snap to (be pulled toward)
the nearest grid intersection or guide when you draw, move, or resize the
objects.

The exact range within which an object snaps to guides is called the snap-
to zone, which you can adjust. When you select both the Snap To Guides
and the Snap To Document Grid commands, the grid takes precedence.

Keep the following guidelines in mind as you align objects to guides and
grids:

To snap an object to a guide, drag an object toward a guide until one or
more of the object’s edges is within the guide’s snap-to zone.

Guides must be visible for objects to snap to them. However, objects
can snap to the document and baseline grids whether the grids are
visible or not.

Objects on one layer snap to ruler guides visible on any other layer. If
you don’t want objects to snap to guides on a certain layer, hide that
layer’s guides.

To snap the text baseline to the baseline grid, choose Grid Alignment >
Roman Baseline from the Control panel menu or Paragraph panel
menu. Alternatively, set Grid Alignment to Roman Baseline from the

Choose Edit > Preferences > Guides & Pasteboard (Windows) or
InDesign > Preferences > Guides & Pasteboard (Mac OS).
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Select Guides in Back, and click OK.2



Smart Object Alignment

Smart Dimensions

Smart Spacing

Smart Cursors

column style Grid Settings.

For the baselines of text to snap to the baseline grid, press the Align to
Baseline Grid button  for individual paragraphs or paragraph styles.

Use smart guides

The Smart Guides feature makes it easy to snap objects to items in your
layout. As you drag or create an object, temporary guides appear,
indicating that the object is aligned with an edge or center of the page or
with another page item.

By default, the Smart Guides feature is selected. You can turn off smart
guides, or you can turn off any of the smart guide categories:

Smart object alignment allows for easy snapping
to page item centers or edges. In addition to snapping, smart guides
dynamically draw to indicate which object is being snapped to.

Smart dimension feedback appears when you’re
resizing, creating, or rotating page items. For example, if you rotate one
object on your page 24 degrees, a rotation icon appears as you rotate
another object close to 24 degrees. This hint lets you snap the object to the
same rotation angle of the adjacent object. Similarly, as you resize an
object next to another object, a line segment with arrows at each end lets
you snap the object to the same width or height as the adjacent object.

Smart spacing lets you quickly arrange page items with the
help of temporary guides that indicate when the spacing between objects
is even.

Smart cursor feedback appears in a gray box as X and Y
values when you’re moving or resizing object or as a measurement when
you’re rotating values. The Show Transformation Values option in Interface
preferences lets you turn smart cursors on and off.

Choose View > Grids & Guides and make sure that Snaps To Guides
is selected (checked).
Note: The Snap To Guides command controls both snapping to
guides and snapping to the baseline grid.
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To specify the snap-to zone, choose Edit > Preferences > Guides &
Pasteboard (Windows) or InDesign > Preferences > Guides &
Pasteboard (Mac OS), type a value for Snap To Zone, and click OK.
The Snap To Zone value is always in pixels.
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For a video tutorial on using smart guides, see
www.adobe.com/go/lrvid4029_id.

Turn smart guides on or off

Choose View > Grids & Guides > Smart Guides.

Turn smart guide categories on or off

Note: To turn off smart cursors, which displays the X and Y values of
objects you mouse over, deselect Show Transformation Values in Interface
preferences.

Change the appearance of smart guides

Tips for using Smart Guides

Smart Guides take effect only on page items and intersections
that are in the current page view. If you have many objects on a
page and are trying to align an object to another object or
objects in particular, zoom in on that area specifically.If you don’t
want Smart Guides to snap to column guides, turn off Snap To
Guides temporarily by choosing View > Grids & Guides > Snap
To Guides.The Smart Guides feature is accurate regardless of
zoom percentage, so it isn’t necessary to zoom in to see if two
objects are really aligned at their left edges, for example.

More like this

Layers

Customize the pasteboard and guides

Open the Guides & Pasteboard preferences.1

Indicate whether you want Align To Object Center, Align To Object
Edge, Smart Dimensions, and Smart Spacing turned on or off, and
click OK.
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Open the Guides & Pasteboard section of the Preferences dialog box.1

Choose a different color from the Smart Guides menu, and click OK.2

http://www.adobe.com/go/lrvid4029_id
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https://helpx.adobe.com/indesign/using/creating-documents.html#customize_the_pasteboard_and_guides
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