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ARCH 2491 
Computer Generated Architectural Presentation Drawings
CUNY - New York City College of Technology 
Architectural Technology Department 
Instructor: Anne Leonhardt 

CLASS 1        08.31.2011 
Rhino Introduction – Points, Curves, Surfaces, Solids, Booleans 

Interface will not be covered explicitly in this handout. 
Remember that a brief introduction to the interface of Rhino is available here: 

Rhino Interface: 
Rhino Interface/Tutorial 1 
http://www.paramod.net/post043/rhino001.html 



Rhino is primarily a Nurbs Modeler. Nurbs stand for Non-Uniform Rational B-Splines. This basically means 
that smooth surfaces can be created through mathematical formulas.  

In traditional Modelers, surfaces are defined by a series of flat 
planes joined together to create a faceted surface.  

Nurbs modelers allow you to create smooth complex surfaces 
by defining a couple of points that can then be manipulated.  

Points
[A point shows an exact position or location on a plane surface. It is important to understand that a point is not a thing, but 
a place. We draw a point by placing a dot with a pencil. This dot may have a diameter of 0.2mm, but a point has no size. 
No matter how far you zoomed in, it would still have no width.]  

www.mathopenref.com/point.html

Points are not very exciting in Rhino, but they are important to keep in mind as we explore the basic tools they support. 
Points can be placed, but do not appear when rendering.  

Curves 

In Rhino, points can be 
connected up to form multi-
segmented lines called curves. 

The shape of the curve 
depends on the mathe-matical 
formula used to generate it. To 
the left you can see how the 
same control points generate 
different geometries based on 
the degree of the curve. The 
larger the degree of the curve, 
the greater the range of 
influence of the control points. 

Curve Primitives – “Circle”, 
“Arc”, “Ellipse”, “Parabola”, “Hyperbola”, “Conic”, “Helix”, “Spiral” 
All of these curve primitives will produce their associated curves in your Rhino model and have specific options related to 
their function that appear in the command prompt. 
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Surfaces 
Just like points can be connected to form lines and curves, curves can be connected to form surfaces. Surfaces in rhino 
can be created in multiple ways. We will go through a few now. You can enter any of the following commands without the 
“” quotes in order to initiate the command. 

“Plane” command: 

Creates a planar surface element based on the coordinates entered. 

“PlanarSrf” command:  
Creates a planar surface element based on a collection of planar curves. 

“Loft” command: 
Loft creates a surface between two or more curves that act as control geometry. Lofts can be planar (flat) or have 3D 
contours. 

“ExtrudeCrv” command: 
Allows a surface to be extruded up from a profile curve 

Solids
In Rhino, surfaces can be joined together to form solids. Surfaces that have been joined to each other are called 
polysurfaces. There are many methods to creating solids, and here we will cover a few of them. 

Solid Primitives – Box, Sphere, Cylinder, Cone, Truncated Cone, Pyramid 
All of these commands will produce their related solid primitive. Check the command prompt for options related to each 
specific command. 
“ExtrudeCrv” command: 
Solids can also be created from a closed curve. Create a “Rectangle” and then “ExtrudeCrv.” If the capped option is 
active, the extrusion will have end caps as shown on the left. If the capped option is set to “no” then the extrusion will be 
open, as shown on the right. 



“Slab” command: 
Slab creates a “thickness” and “height” from a curve. You will be prompted to enter the thickness, the side where the 
offset should go, and the height all at the command prompt. 

“Join” “Group” and “Explode” commands: 
Make a box and “Explode” it. Notice that it is all separate planes. Select all of the planes and “Join” them. Now they are 
together again. Note that “Join” is about geometry grouping. If you “Group” the objects, they will all select together, and 
look exactly like a solid but they are NOT a solid, and you can NOT perform solid editing commands on a group. 

“ExtractSrf” command: 
Allows you to remove a surface from a joined object without exploding it. Enter the command, pick the surface you want to 
extract, and hit enter. The surface will un-join the original solid. 

“Cap” command: 
Takes an open surface with planar holes and caps them creating a solid object. Extrude a rectangle with the caps option 
set to “no”.  Select the resulting surface and enter the “Cap” command. The open rectangular polysurface should close 
into a solid. 

“BooleanUnion,” “BooleanDifference” “BooleanIntersection” 
Create a sphere and a box and intersect them. Now let’s Boolean these objects using each of the three commands. 
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               BooleanUnion  BooleanDifference     BooleanDifference2 BooleanIntersection 

Remember that with BooleanDifference, the object you choose FIRST is the object that is kept, and the object you choose 
SECOND is the object that is carved out. 

Object Manipulation 
“Rotate 3D” command: 
In order to rotate objects in 3D space you must use the rotate3D command. Execute the command then choose your 
objects to rotate. Choose the axis of rotation by specifying the first and second points to rotate around. This line WILL 
NOT MOVE. The object will rotate AROUND it. Imagine the earth. It spins in space, but at the absolute north pole, and the 
absolute south pole, the coordinate do not change, only the orientation. The first line you are drawing is this axis of spin. 
You will then choose a point which will determine the reference angle for rotation. The last point you pick will determine 
the angle of rotation. 

 
Orient Command 

To orient an object to another: moves, copies, rotates and scales the object using two reference and two target 
points. 

 
1. Select one object. 
2. Pick two reference points on the object. 
3. Pick two target points on the second object: the first and second reference points will match these locations. 

Constructing Page Layouts for Printing, Background colors, and Orienting objects 
 

1. Select View > Page Layout > New Page Layout 
2. In the New Page Layout dialog, choose printer (or None), set the paper size to 11 x 17” landscape, set the Initial 

Detail Count to 4, and click on the OK button. The four viewports open at this time in your drawing will appear in 
the layout viewports. 

 
 
 
 
 



 

     
 
 
 
 
 
 

          The Initial Detail Count refers to the number of detail viewports that will be constructed  
          automatically by the system. If you choose 0, you will have a blank page layout.  
 

3. To manipulate the viewports, activate it by double clicking inside it: you can rotate, pan, zoom, and orbit, or by 
choosing the “Select View” icon, change to a different view.

4. To lock a detail, so the selected view is not altered, select the edge of its box (it will turn yellow), go to the 
Properties list, select detail, and in the dialogue box and check “Lock”. 

 
5. To add shading to a viewport, double click on the viewport to enable it. Then left click on 

the shaded viewport command icon.     
 
 
 

Background color 
Background colors for the screen are found in the Options > Appearances > Background color 



Rhino 3D an Overview
New York City College of Technology
Written By-John Eberhart

Rhino is designed as a Nurbs Modeler.  Nurbs stand for Non-Uniform Rational B-Splines.  This basically means
that smooth surfaces can be created through mathematical formulas.  What this means to us is that complex
smooth forms can be created that are highly adjustable and mailable for the designer.  In traditional Modelers,
surfaces are defined by a series of flat planes joined together to create a facetted surface.  Nurbs modelers allow
you to create smooth complex surfaces by defining a couple of points that can then be manipulated.  However, when
it comes to simple modeling, Rhino is a very easy to use and a highly intuitive modeler.

Rhino 3D Basic Modeling Tools:

The Modeling Windows

The Modeling Tool
Pallet

View Controls

Rendering Controls

Snap Etc. Controls

Tool and Command
Prompt

Rhino has a typical Modeling interface.  By default it is composed of four view points and a tool palette on the left.
At the bottom are the ortho and object snap controls.  At the top are the Pan and Zoom Controls, as well as the
tool command prompt.

Assist/Properties Pallet



Setting up grids and units for accurate modeling:

Click on the units Tab, and select either Millimeters or
Inches.  Match your Unit setting with the Distance
Display

Units Tab

Units Setting

Display Setting

Click on the Grid Tab, and set a grid snap and
grid spacing.  Note: if you are using Feet and
inches a grid unit of 8 is best.  If you are using
metric, then a grid unit of 10 is best.

Grid Tab

Snap Spacing

Major Grid Lines
Match your units

Click on File>Properties to open the settings window.

Snap, Ortho, Planar, OSnap, Record History, and S-Track:

The bottom of the Rhino interface is a number of drawing aids.  These allow you to lock lines and Snap as needed.

Record History: Allows you to link lines to surfaces.  If you
change the line, it will update the surface (Kind of Works)

Osnap: (Object Snap)Activates the snap menu.  Will snap lines
to geometry as you draw.

Planar: Keeps curves in a set plane as you draw from one view
to another.

Ortho: Locks lines to 90 Deg.  Hit F8 to toggle or hold down
shift key while you draw.

Snap: Toggles the grid snap on or off that we just set.

Project: Will project line snapped to geometry onto the ground plane, useful for creating
plan outlines.

S-Track: Allows you to snap projection line from multiple types of geometry.

Disable: Disables the O-Snap functions.



The Tool Palette:

Selection Tool: Used to select and move objects

Draws Points:  Used to place single points.  This can be used with rail sweeps.

Draws Lines and Curves:  Used to construct splines for surface and object generation. See
Below

Draws Circles and Ellipses: Used to construct closed curves.

Draws arc’s.

Draws Rectangles.
Draws Polygons.
Fillet Tools:  See Below.  Hold down mouse for more options.
Surface Tools:  See Below.  Hold down mouse for more options.
Advanced Surface Tools:  See Below.  Hold down mouse for more options.
Solids Tools:  See Below.  Hold down mouse for more options.
Boolean Tools:  See Below.  Hold down mouse for more options.

Curve from Object Tools:  See Below.  Hold down mouse for more options.
Mesh Tools:  See Below.  Hold down mouse for more options.

Join Tool:  Used to join together two surfaces.
Explode Tool:  Used to break apart joined surfaces.

Trim Tool:  Used to cut a surface with another object.
Slit Tool:  Used to cut a surface with a cutting object.

Group and ungroup tools.

Control points on and off toggle tool.
Point editing controls:  See Below.  Hold mouse down for more options.

Analysis Surfaces Tools.

Place text tool.
Transform tools:  Hold mouse down for more options.

Copy Rotate and Scale Tools.

Most of the items in the tools palette can also be accessed in the menus palette.  In the Menus palettes there are
also more specific tools associated with its menu item not listed in the tools palette,

Curve Tools are used to adjust and fix existing curves.
These include Fillets, Chamfers, Off Sets, Fix Points,
Simplify and Rebuilding Curves.



Surface Tools:  This palette is used to generate surfaces from
Points and Curves. Lofts, Surface from Curve Network, Sweep
Along one and two rails, Revolve, Patch, and Drape Functions.

Surface editing tools:  These are used to edit, adjust, fix and
rebuild surfaces.

Solid Tools Pallet.  This is a typical pallet of object primitives that
can be created.

Solid Editing Tools: These includes difference, union, intersec-
tion.  As well as fillet, cap holes, and extract surface.

Curve From Object Palette:  This is used to generate curves from
objects that then can be used to generate more surfaces.  You
can also generate a series of contours from an object, section
curves, etc.

Mesh Tool Palette.  This is used to extract mesh surfaces and
objects from nurbs surfaces.  This is useful for exporting into
other programs.  You can also create direct mesh objects without
creating a nurbs object first.



Creating Objects Using Boolean Commands:
To create an object in Rhino, click on one of the Solids from the solids tool pallet:

This box is defined by two points
and a height.

Height

Two base points

Note, use multiple windows to create
your box.  Define the base points in either
the top view or the perspective view, then
activate ortho at the bottom of the
modeling window, and then extrude the
box in either front or side view.

Creating complex objects in Rhino is easy to do using the boolean operations.  Simply build the object you want to
cut and place it in the correct location relative to the object you want to keep.

Object  to Keep
Object  to cut (Shown High lighted)

Deselect all objects, and click on Solid, then Difference.  Note
in this same menu you have Union and Intersection as well.

Click on the object you want
to keep, first.  Hit return, or
right click.  Then click on the
object or objects to want to
cut from with.  Hit return or
right click again.

Cut Object



Along with normal objects, you can adjust “blobs”  Start with a
sphere.  Click on the solids menu>Sphere>Center, Radius.
Click in the screen and draw a sphere.

You can now move the control points that define the sphere
by clicking on the point editing tool.  With the sphere
selected, click on this tool to turn on point editing.

Now in plan or front view select a series of points.  Then
click and drag the points stretching out the sphere.

Note: This will not work with rectangular solids, but will work
with spheres and surface.

Control points on, and some points
selected:

Selected points moved and sphere is
deformed

Adjusting Surfaces by Editing its Control Points:

Rendered Sphere.

This process can be applied to almost any Nurbs surface.



Moll 11.21.11

Visual Studies I: Arch 1191 

Assignment Number: 9 

Computer Program(s): McNeel Rhinoceros Cont’d 

Student Learning Objectives:  

Upon successful completion of this assignment, the student will:

1. Understand how to model in 3D a simple geometric object in McNeel Rhinoceros (Rhino). 
2. Know how create a Rhino model file. 
3. Know how to toggle between the four standard view points. 
4. Know how to set up units. 
5. Know how to set up a grid. 
6. Know how to use the solid tools palette. 
7. Know how to use Boolean operations (addition, subtraction) in order to create more complex forms. 
8. Know how to use more complex modeling tools: surfaces, meshes, etc. 

Assessment:  
To evaluate the student’s achievement of the learning objectives, the professor will do the following:

1. Evaluate the student’s understanding McNeel Rhinoceros by examining both the digital file and the 
hard copy output.

Project Description: 
In this assignment, you will model in three dimensions digitally your assignment 9 from Arch 1110, Extruded 
Geometries. 

Process:  

1. Create a new file in Rhino. 
2. Choose units, inches and match units with Distance Display. 
3. Choose grid tab, and set grid snap and grid spacing: a grid of 8 is best when working in inches. 
4. Choose one view port to begin your drawing.  
5. Draw the 48’ square that is the limits of your drawing. 
6. Reconstruct your chosen square design in Rhino, Autocad, or import a raster of your design and trace 

over it. 
7. Create the solids as defined by the rules of shape generation: 

a. At point/intersections, create a column, either a 2 foot diameter cylinder or a 2 foot square 
prism centered on the point/intersection. 

b. At single lines, walls are extruded and must be 2 feet wide and centered over the defining line. 
The length should be one foot more at each end of the line. 

c. Volumetric elements are defined by some combination of lines, both straight and curved, that 
enclose an area. 

8. Use Boolean Operations to create volumetric elements:  
a. Volumetric elements are defined by some combination of lines, both straight and curved, that 

enclose an area. 
b. Positive volumes are defined by extending one foot past the defining lines.  
c. Negative volumes are defined by extending one foot inside the defining lines. 
d. Maximum height of any positive element is 24 feet above grade. 



e. Negative volumes may not extend more than 4 feet below grade. 
f. All vertical dimensions must be in one foot increments. 
g. The tops and bottoms of all extruded elements must be flat horizontal surfaces. 
h. Create a minimum of two cases of intersecting elements of different heights. 
i. See additional rules in Arch 1110’s Assignment 9. 

9. Complete three dimensional model of Extruded Geometries design. 
10. Create page layout for printing: 

a. Select view>Page Layout>New Page Layout. 
b. Choose printer. 
c. Choose page size: 11x17. 
d. Choose orientation. 
e. Set initial Detail Count to 4, hit OK. Detail count is equal to the number of viewports in 

Autocad. Note Autocad will automatically create a viewport for each tab. 
f. Manipulate viewports: 

i. Double click inside the viewport. 
ii. Rotate, pan, zoom, and orbit or use the select view icon. 
iii. Lock chosen view. 
iv. Shade chosen view. 
v. Choose background color. 

11. Render your composition: 
a. Set the renderer to Rhino renderer. 
b. Choose resolution 
c. Background color 

12. Export images: screen capture or export file type. 
13. Import images into Adobe Illustrator. 
14. Format images with title block. 
15. Print hard copy. What are the differences between working in three dimensions by hand and working 

digitally? Pros and cons of each? 



Rhino 3D - Advanced Features
New York City College of Technology
Written By-John Eberhart

This tutorial covers a series of advanced modeling features.  Some of the features are very specific to Rhino. Others
will appear as variations of tools in other modeling programs.

Lofting a Surface:  The term lofting come from the ship building industry.  This is the method of placing a surface
over a ship skeleton.  In Rhino you generate a lofted surface over a series of curves spaced out.  To loft a surface,
create a series of splines, and arrange them to define the soon to be formed surface.

Select Surface>Loft.  At the command prompt, click on the splines in the
correct order.  Click Enter or Right Click when done.  The following window will
appear:  (Note, click to one side of the lines to set the direction of the loft)

The following Loft Options box will
appear.

Under the Style drop down you will have
a number of loft options.

Normal: The most mathematically
efficient loft
Loose: Will create a smoother loft that is
not based exactly off of the loft curves,
but averaged.
Tight: Constructs a loft the is exactly on
the various loft curves
Straight Sections: Will create a series of
ruled surfaces between loft lines
Developable: Will create lofts that can be
flattened out on a single sheet.
Uniform: Guarantees that every control
point affects the surface exactly the
same way.



Selecting this will create a closed lofted surface, check and click preview to
see.

Align Curves: This is used to flip the direction of a curve.

Rebuild With XX Control Points.   This allows you to set a number of curve
divisions refining  the smoothness of the surface.

Set the loft to rebuild with 20 points and click Preview to see the surface.  If
you like it, click OK.

The Lofted Surface

Rebuilding Surfaces: Often after you create a curve or surface, you will need to
rebuild it.  Rebuilding a curve or surface changes the
number of points in a curve or the  number of points in a
profile curves used in creating a surface.  Each point then
has a line (Iso-curve) running through it.  Rebuilding a curve
or surface changes the number of points in each line.  This
will in effect make the curve or surface smoother (reducing
points) or more flexible (increasing curves)

Select a surface or curve, then click on Edit>Rebuild

Change the number of points in both the
U and V Directions

Keep the Curve Degree to lower than 3

Click Preview to preview the new Curve or
Surface.  Click OK to rebuild.



Trim and Split:
When dealing with complex surfaces, you will most likely need to cut holes and trim
surfaces.  This can be done with the boolean tools, but there are times when they do
not provide the level of detail that the trim and split tool offer.

Trim and Split is basically the same tool, the only difference is that the trim tool will
delete the piece being cut.  Split will just cut the objects.

Trim

In this example, I have placed a
cylinder through a lofted surface.

Split

Original Surface with 20 Control Points

Same Surface “Rebuilt” with only 6
control points

Rebuilt Curve with only 6 control points

Original Curve with 16 Control Points



Click on the Split Tool.

At the prompt, Click on the lofted Surface, this is
the object to be split.

Click Enter.

Then Click on the Cylinder.  This is the object to
cut.

Click Enter to split the object

The Object Split (Note: I deleted the cylinder)

The Trim Tool will automatically delete the cutting object.  Also in this example, I just have the circle
shape.  I do not need to extrude a cylinder through the lofted shape.

Click on the Trim Tool

At the Prompt: Select Cutting Ob-
jects, choose the Circle and hit Enter.

At he Prompt: Select object to Trim,
select the lofted surface

NOTE: Do this through the Front
Elevation, otherwise the lofted shape
would be cut through the perspective
view.

Note: If you click on the lofted
shape inside the circle, the inside
circle will be deleted.  If you click
outside the circle, the outside will
be deleted.



Trimmed by clicking inside the circle

Trimmed by clicking outside the circle

Patching a Surface:  Patching a surface is used to create a uniform surface from a series of closed curves.  The
most common use for this tool is generating terrain models.

Select Surface>Patch

At the Patch prompt, click
in order the closed curves
to be patched.

Adjust the setting
to get the desired
result.  Click on
the preview button
to see a preview
of the patched
surface.

Click OK to
generate the
patched surface.



Duplicating and Projecting Curves onto Surfaces:
You can generate curves from existing geometry and then project that onto other geometries.

In this example, I have added a plane to the model with the trimmed lofted surface.  I am going to project the holes
onto the surface.

Step One: Duplicate the Edge
of the hole.  Click on
Curve>Curve From
Objects>Duplicate Edge

Surface to project the curve
onto

Lofted Surface with the hole

At the Command Prompt, select the edge to duplicate.  Note: Sometimes
you will have to click on many segments of an edge to duplicate.  If this is
true, you will also need to join the segments after they are duplicated into
one singe curve.



Step Two: Project the duplicated edge curve onto the surface.

Select Curve>Curve From Objects>Project.

At the Command Prompt, Select Surfaces...to project onto, select the
surface.

NOTE: You have to do this through an orthogonal view.  If you do it in
perspective view, it will perspectively project the curve.

Click the Surface to project
onto in an orthogonal view

The curve projected onto the surface.

Delete the surface and you are left with
the projected curve.

I lofted the two Edge curves and filleted
the intersection of the two lofted surfaces.

Lofted Surface

Filleted Surfaces



Capping Holes and Generating Surfaces from Edge Curves:
Often you will need to cap holes.  If the curves that make up the edge of the
hole are planar (They all fall inside a single plane, you can use the Planar
Holes tool.

Select Surface>Planar Curves.

Select the curves to cap and Hit Enter.
(Note: You can select more than one curve.)

Capped Surface

To cap a non-planar surface, you will need to use the Edge Curves tool.  The problem with the edge curve tool is
there is a limit to the number of curves you can select (only 2-4 curves)  To get around this you can join additional
curves.  However, the result can be less then satisfactory.

A common use for the Surface from edge curves is to box out two surfaces.

We will use this tool to create surface
along the two edges of this surface.
(Note: We could loft it but it is hard to do
it on all four sides.



Step One: Snap Curves between the two Surfaces.

Using the curve tool, and with the end point O-Snap active and Project off, snap two lines between the two surfaces.

Two Curves Drawn between
the two surfaces.

Step Two: Activate the Edge
Curves tool by Clicking on
Surface>Edge Curves

Select the 2 Curves
and 2 Edges that will
make up the surface.

The surface is created.

Model with all four surfaces created



Object Manipulation using Caging:

Caging allows you to transform a complex object using a small number of edit
points.

Caging is a two step process, first you define the shape (Cage) that will be used to
box around the object and transform.

To do this select Transform>Cage Editing>Create Cage

At the prompt, draw a 3-point box around the object and hit Enter.  A box is formed
around the object.

The next step is to Edit the Cage which will transform the object.

Click Cage Editing>Cage Edit.

At the prompt, Select Captive Objects, select the objects to trans-
form.

At the next Prompt, Select Control Object, select the caged box.

At the next Prompt, select Global, and points are created throughout
the cage.

Select Points in the cage and move the
points

Transformed Object



Blend Surface Feature:
Rhino has a number of tools to match up two separate surfaces.  These are
located in the surface tools pallet, or in the surface pull down menu.

These are two surfaces that I want to blend together to create a single surface that
will transition the two surfaces.
Step One: Select “Surface” from the menu bar, and then “Blend”.

Step Two:  In the command prompt at the top of the window, under “Select First Set of Edges”, click on the edges
of the first surface to blend.  After you have selected all of the edges, hit return or right click.

Fillet Surface

Blend Surface



The command prompt will now say “Select Second Set of Edges”.  Select the second set of edges, and hit return or
right click.

Step Three:  At the command prompt “Select Seam Point to Adjust.  Press Enter When Done” you will get some
additional options.  You will also notice that you will get two arrows.  These arrows allow you to adjust the location of
the seam to the blended surface and adjust the direction of the surface.

Seam of Blended Surface Adjusted.

Also in this command prompt you will notice three options “Flip Direction, Automatic, and Natural”  The flip direction
option allows you to orient the arrows in the same direction to avoid a twisted surface.  Automatic will generate the
surface automatically.  Natural will give a more relaxed look to the surface.  Click Enter to Continue.

Generated Surface

Two Arrows

A preview button will appear
where you can adjust the
settings.



Using Blocks in Rhino:
Often you will use the same part created in Rhino many
times.  If this is the case it is best to use blocks. Blocks
have two major advantages:

1. It keeps the files sizes small and thus you can create
complex models without having large files sizes.

2. If you need to update the part, all the instances of that part
will be updated.

Complex Form that will be turned
into a block.

Select Edit>Blocks>Create Block Definition.

At he prompt, select objects to define block,
click on objects and hit Enter.

At the Prompt, define base point, click to set an
insertion point for the block.

The following window will appear:

The block Definition properties will appear.

Give the block a Name and hit OK.



Inserting a Block Definition:
After you create a block, you can then insert instances of the block
into the Rhino model.  An instance is a reference of an original.
This is how you can keep the file sizes down.

Choose the Block to insert

Select Various insertion settings

Click OK to insert

The block will be bound to the mouse
and when clicked, will be inserted



Linking External Models as Blocks:

Another powerful way to use blocks is to link a series of external
models into a “Master” Rhino Model.  This allows updates in different
models to be automatically updated in the master model.

Step One: Create a Block from an external file.  Select
Edit>Blocks>Insert Block Instance

Select File

Select a Rhino Model to
insert



Linked File Name and Pathway is displayed

(NOTE: It is a good idea to keep all files in the
same folder to avoid broken links)

Under External File,  Choose Link

Click OK to place in model

Linked Models

If  changes are made in the
original model the changes
will appear in the model
with the block definitions.

Change Made to
Original Model File

To update the Link Model, click on Edit>Blocks>Block Manager

Select the Block to
Update, and click on
Update.

Blocks are Updated



Make A 2D Drawing:

In Rhino you can generate a series of 2D Drawings from 3D forms these drawings are a
series of 2D curves that can be imported into illustrator or flash.

To make a 2D drawings, click on Dimensions>Make 2-D Drawing.

At the prompt, Select objects to draw, select the objects.

The following Window will appear:

Choose 4 View USA

Click OK

Four Views, Top, Front, Left,
and Perspective are created.

These views are located on
the ground plane.  If you
select a view and export it
from the top view it will be
oriented in the correct direc-
tion.
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AutoCAD to Rhino 
        
Cleaning your AutoCAD drawing is one of the most important parts of the process. A clean .dwg will allow 
you to easily produce a 3D model, while a messy .dwg can cause many headaches in the long run.  
 
Make a Copy of your FilesMake a Copy of your FilesMake a Copy of your FilesMake a Copy of your Files    
Before you make any changes to your file, it is recommended that you use File>File>File>File>SaveSaveSaveSaveAAAAssss to create a second 
set of files that will become your underlay for modeling by appending something to the end of the filename. 
This is important as you do not want to modify your working drawings accidentally.  
 
NOTE: Make sure that you choose AutoCAD 2004 as your filetype when you SaveAsSaveAsSaveAsSaveAs. The 2007 and 2010 
filetypes WILL NOT import into Rhino. 
 
DeleteDeleteDeleteDelete    UnneededUnneededUnneededUnneeded    InformationInformationInformationInformation    
It is important that we remove any extraneous information from the drawing: 
 
Text and Dimensions 
Delete all text and dimensions. You will not need them in Rhino and they will only serve to cause you 
headaches if you leave them in your drawing. 
 
Layers 
It is time to leave your layers behind. Turn on all of your layers (assuming that you need all of them in your 
model) and change all of your layers to layer 0. You’ll likely find that you have some objects that still appear 
to be on a layer. These are probably blocks that have been improperly made. We will deal with blocks next. 
 
Blocks 
You may find that the drawings you are working with use blocks for washrooms or bathrooms, kitchens, 
furniture, scalies (people) and other non-architectural elements. It is best to remove all of these blocks from 
the drawing by deleting them. Blocks are also often used to simplify the process of drawing complex 
geometry. These blocks should be simplified (by editing the block directly or using beditbeditbeditbedit) and then exploded 
using explodeexplodeexplodeexplode. 
 
You may need to Edit>Select AllEdit>Select AllEdit>Select AllEdit>Select All and change the layer of your objects to 0 one more time, as blocks can 
have objects set to different layers nested inside them. 
 
NOTE: It is better to delete your unneeded blocks before exploding them as you will often have a hard time 
cleaning up your drawing should you explode first. 
 
Hatches 
Next, we will want to make sure that we clean up any hatches from the drawing. You should just delete 
these objects unless they are highly specific (a brick pattern that has been PROPERLY applied at the right 
scale.) IF and ONLY IF you absolutely need a hatch (think long and hard about this), you can explode that 
hatch and it will import into Rhino. 
 
Helpful Commands: 
Purge, Qselect, Overkill 
 
After deleting the above objects (block instances, hatches, and objects on unneeded layers) you will want to 
purgepurgepurgepurge the file. This helps ensure that your Rhino file will not have hundreds or possibly even thousands of 
unused block definitions, layers, hatch definitions, etc. taking up space and slowing down your model. 
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Open Rhino and Choose File>ImportFile>ImportFile>ImportFile>Import::::    
Make sure that you choose AutoCAD drawing file in the type dropdown. 
 

    
    
Your geometry should appear in your Rhino model. Before doing anything else, groupgroupgroupgroup the drawing. This will 
allow you to select it as an object, rather than line by line. 
 
Create a new layer (right click on the layer palette> New Layer): 

 
 
and place your plan on it (select the plan, right click the layer you made and choose Change Object Layer): 

 
 
Verify your units and dimensions match in AutoCAD and Rhino by using the distance command in both 
AutoCAD and Rhino on the same geometry. 
 
Now we want to simply repeat the process with each of the underlay drawings you will be using. 
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Rhino 2 – Surfaces continued, Advanced tools – Sweep, Revolve, BlendSrf, ChamferSrf, Fillet, Contour 
 
Interface will not be covered explicitly in this handout. 
Remember that a brief introduction to the interfaceinterfaceinterfaceinterface of Rhino is available here: 
 
Rhino Interface:Rhino Interface:Rhino Interface:Rhino Interface:    
Rhino Interface/Tutorial 1 
http://www.paramod.net/post043/rhino001.html 
 
SurfacesSurfacesSurfacesSurfaces    
Sweep1 
Create a rail curve and a profile. Think of the rail curve as the path that will be traveled, and the profile curve 
as the curve that will be travelling on it (like a rollercoaster).  The red path represents the profile curve in the 
example below. The options box controls may require some tweaking to get the desired effect. Use 
CommandHelp for an exhaustive description of the options. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

Sweep2 is very similar to sweep1, however you can select 2 rail curves to control your profile curves. 
Remember, the order is important. Select the 2 rail curves FIRST, then select the profile curve. 
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Revolve 
Revolve is a command that creates a surface from profile curves, a revolution axis, and angle. First draw a 
profile curve that you want to revolve. Invoke the command. Rhino then asks you for the curves to revolve. 
You can select more than one. Normally these curves are 2-dimensional, or flat, but they can also be 3D. 
Then choose a revolution axis. This is the axis around which our objects will rotate (think of a CD. A line 
drawn straight up and down through the center of the hole would be the axis of rotation). The length of this 
line is not important, only the direction. Then choose the angle through which you want to rotate the curves. 
360 is a full circle, 180 half a circle, and so on. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
BlendSrf 
Blend is a command that takes 2 different surfaces and creates a third surface that literally blends between 
the first two. There are different options available for the blend, which we will cover here and that are also 
covered in the CommandHelp. Invoke the command. Rhino will ask you to choose the edges to blend 
together. Choose the two edges facing one another. Hit enter. Rhino will then present you with an options 
box, and several options from the command line. Notice the Continuity options are set to G2. The number 
describes how “strong” the influence is from that edge’s surface. Change the Continuity _1 from G0, one by 
one, to G4 to see how this effects the shape of the resulting surface. Move the sliders to change the 
strength of influence for each edge. You can also edit the handles directly to change the shape of the blend 
surface. 
 

  
 
ChamferSrf 
Chamfer creates a beveled edge on two adjacent surfaces. Invoke the ChamferSrf command. Rhino will 
then prompt you for the two surfaces to be chamfered. Choose the two surfaces and hit enter. After hitting 
enter, Rhino then prompts you for the distances to chamfer. You can cut more from one surface than the 
other if you make these distances unequal.  
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FilletSrf 
Fillet is much like chamfer in that it acts on two adjacent surfaces. Instead of producing a bevel, or cut, 
however, fillet produces a radius join. Invoke the FilletSrf command. Rhino will prompt you for two surfaces. 
Choose the two surfaces and hit enter. Rhino will then prompt you for a radius to cut. Choose your radius 
and hit enter. 

 
 
 
    
    
    
    

    
Contour 
Contour creates a series of cut planes through an object and makes curves at those locations. It is possible 
to choose the distance between contours and their direction. Choose an object for contour. Invoke the 
command. Choose the base point for the contour plane (it does not matter where this is). Choose a second 
point. The second point determines the direction that the contours will be made, so if you choose a point 
directly above the first point on the z axis, your contours will all be made in the x-y direction. If you set the 
JoinCurves option to ByContourPlane, each contour curve will be a single object. When you hit enter, the 
command will generate contour curves. 
 

 
 
Explode 
Explode will take a solid object and separate it into its constituent parts. For instance a cube would become 
6 separate surfaces when exploded. Sometimes this is useful because we want access to each side 
individually. More often than not, however, it is easier to work with one side at a time. We can extract sides 
individually by using: 
 
Extractsrf 
Extractsrf will pull a surface from a solid for editing. The remainder of the solid will stay together in a 
polysurface (poly meaning many). 
 
Join 
Will take a series of surfaces and join them into one polysurface. 
 
Group 
In Rhino, objects can be organized into groups using the “group” command. Grouping objects together 
creates an organizational relationship. This relationship does NOT create solids or new geometry. Surfaces 
grouped together using the group command are not polysurfaces and have only an organizational 
relationship. These surfaces are not related geometrically. 
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Commands that work similarly in AutoCAD and Rhino for you to try: 
Trim, extend (works with surfaces as well), stretch, scale, rotate (in addition to rotate3d), chamfer and fillet 
(works with curves as well), 
 
Commands that are new but work like commands we have already covered to try: 
Curveboolean – Booleans with curves 
Moveedge – Move the edge of a surface 
Maelstrom – Rotates part of a surface, solid, or curve leaving the rest stationary 
Arrayhole – Creates an array of holes in a solid or surface 
Deletehole – Removes a hole in a solid or surface 
Rotateedge – Rotates an edge of a surface 
Rotateface – Rotates a face in a solid 
Rotatehole – Rotates a hole in a surface or solid 
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Visual Studies I: Arch 1191 

Assignment Number: 10 

Computer Program(s): McNeel Rhinoceros Cont’d and V-Ray 

Student Learning Objectives:  

Upon successful completion of this assignment, the student will:

1. Understand the differences between creating a perspective by hand using the office method/plan 
projection method and setting up cameras and rendering digitally in McNeel Rhinoceros and V-Ray. 

2. Understand how to apply materials in V-Ray. 
3. Understand how to create lighting in V-Ray. 

Assessment:  
To evaluate the student’s achievement of the learning objectives, the professor will do the following:

1. Evaluate the student’s understanding McNeel Rhinoceros and V-Ray by examining both the digital file 
and the hard copy output.

Project Description: 
In this assignment, you will create and render perspectives of your digital version of Extruded Geometries, 
Assignment 9 and compare to your plan projection perspectives by hand. Remember that perspectives are the 
only drawings that will describe the experience of a space. It is important for this reason to make sure that the 
horizon line is at 5’6, the average eye level of a human being. While worm’s eye views can be interesting, they 
do not describe how we experience most spaces, unless perhaps it is a yoga studio and we are often lying on 
the floor. Bird’s eye views are great for larger planning exercises as found in urban planning. 

Process:  

1. Create cameras at different positions around your model.  
a. Be sure that your camera’s are at a height of 5’-6” above floor level for your model.  
b. Be sure that the target for your camera is also at a height of 5’-“6”. 

2. Check perspectives by doing a simple render: 
a. Set the renderer to Rhino renderer. 
b. Choose resolution 
c. Background color 

3. Use V-Ray for advanced rendering. 
a. Apply materials to model 

i. Apply default material. 
ii. Edit default material so that you have the following three versions of your model:  

1. One version should be a simple white model 
2. Another version should play with solid, translucency, and transparency. 
3. Another version should use textures. 

b. Apply lighting in V-Ray: 
i. GI or Global Illumination does not create shadows as there is not direction. 
ii. Add depth with Rectangular Light: Click on Spot light icon, select Rectangular light, 

create light in top view and place it in elevation at a height of five times the elevation 
of your model. 


