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Interface

Interface: 
Icons, Menus, Pallettes, View Manipu-

lation, Command Help 

Rhino is designed as a Nurbs Mod-
eler. Nurbs stands for Non-Uniform 
Rational B-Splines. This basically 
means that smooth surfaces can 
be created through mathematical 
formulas. What this means to us is 
that complex smooth forms can be 
created that are highly adjustable 
and malleable for the designer. In 
traditional Modelers, surfaces are 
defined by a series of flat planes, 
joined together to create a faceted 
surface. Nurbs modelers allow you 
to create smooth complex surfaces 
by defining a couple of points that 
can then be manipulated. However, 
when it comes to simple modeling, 
Rhino is a very easy to use and a 
highly intuitive modeler.

Rhino 3D Basic Modeling 
Tools:
Rhino has a typical Modeling inter-
face. By default it is composed of 
four view points and a tool palette on 
the left. At the bottom are the ortho 
and object snap controls. At the top 
are the Pan and Zoom Controls, as 
well as the tool command prompt.

Tool and Command Prompt

View Controls

The Modeling Windows

Properties Panel
Rendering Controls

Snap Etc. Controls



Setting up grids

Setting up grids and units 
for accurate modeling:

•	 Click on File>Properties to 
open the settings window.

 

•	 Click on the Units Tab, and se-
lect either Millimeters or Inches. 
Match your Unit setting with the 
Distance Display

Units Tab

Units Setting

Grid Tab

Display Setting

Snap Spacing
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Snap...

Snap, Ortho, Planar, OS-
nap, Record History, and 
S-Track:

The bottom of the Rhino interface 
contains a number of drawing aids. 
These allow you to lock lines and 
Snap as needed.

•	 Project: Will project a line 
snapped to geometry onto the 
ground plane, which is useful for 
creating plan outlines.

•	 S-Track: Allows you to snap 
projection line from multiple 
types of geometry. 

•	 Ortho: Locks lines to 90 Deg. 
Hit F8 to toggle or hold down 
the shift key while you draw. 

•	 Disable: Disables the O-Snap 
functions. 

•	 Planar: Keeps curves in a set 
plane as you draw from one 
view to another. 

•	 Osnap: (Object Snap) activates 
the snap menu. It will snap lines 
to geometry as you draw. 

•	 Record History: Allows you to 
link lines to surfaces. If you 
change the line, it will update 
the surface (Kind of Works)
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The Tool Palette

•	 Selection Tool: Used to select and move objects

•	 Draws Points: Used to place single points. This can be used with rail sweeps.

•	 Draws Lines and Curves: Used to construct splines for surface and object generation. 

(see below)

•	 Draws Circles and Ellipses: Used to construct closed curves.

•	 Draws Arc’s.

•	 Draws Rectangles.

•	 Draws Polygons.

•	 Fillet Tools: See below. Hold down mouse for more options.

•	 Surface Tools: See below. Hold down mouse for more options.

•	 Advanced Surface Tools: See below. Hold down mouse for more options.

•	 Solids Tools: See below. Hold down mouse for more options.

•	 Boolean Tools: See below. Hold down mouse for more options.

•	 Curve from Object Tools: See below. Hold down mouse for more options.

•	 Mesh Tools: See below. Hold down mouse for more options.

•	 Join Tool: Used to join together two surfaces.

•	 Explode Tool: Used to break apart joined surfaces.

•	 Trim Tool: Used to cut a surface with another object.

•	 Slit Tool: Used to cut a surface with a cutting object.

•	 Group and Ungroup tools.

•	 Control Points On and Off toggle tool.

•	 Point Editing controls: See below. Hold mouse down for more options.

•	 Place Text tool.

•	 Transform tools: Hold mouse down for more options.

•	 Copy Rotate and Scale Tools.

•	 Analysis Surfaces Tools.



The Tool Palette

Most of the items in the Tools pal-
ette can also be found in the Menus 
palette at the top or the screen. In 
the Menus palettes there are more 
specific tools associated with its 
menu item not listed in the Tools 
palette,

•	 Curve Tools are used to adjust 
and fix existing curves. These 
include Fillets, Chamfers, Off 
Sets, Fix Points, Simplify and 
Rebuilding Curves.

•	 Surface Tools: This palette 
is used to generate surfaces 
from Points and Curves. Lofts, 
Surface from Curve Network, 
Sweep Along one and two 
Rails, Revolve, Patch, and 
Drape Functions. 

•	 Surface Editing Tools: These 
are used to edit, adjust, fix and 
rebuild surfaces. 

•	 Solid Tools Pallet. This is a typi-
cal pallet of object primitives 
that can be created.

•	 Solid Editing Tools: These 
include Difference, Union, and 
Intersection, as well as Fillet, 
Cap Holes, and Extract Surface.

•	 Curve From Object Palette: This 
is used to generate curves from 
objects that then can be used 
to generate more surfaces. You 
can also generate a series of 
contours from an object, sec-
tion curves, etc.

•	 Mesh Tool Palette. This is used 
to extract mesh surfaces and 
objects from nurbs surfaces. 
This is useful for exporting into 
other programs. You can also 
create direct mesh objects with-
out creating a nurbs object first.



Rhino Basics

Rhino, as mentioned above, is primarily a 
Nurbs Modeler. Nurbs stands for Non-
Uniform Rational B-Splines. This basically 
means that smooth surfaces can be cre-
ated through mathematical formulas. 

In traditional Modelers, surfaces are 
defined by a series of flat planes joined 
together to create a faceted surface.

Nurbs modelers allow you to create 
smooth complex surfaces by defining a 
couple of points that can then be ma-
nipulated.

Points:
[A point shows an exact position or loca-
tion on a plane surface. It is important 
to understand that a point is not a thing, 
but a place. We draw a point by placing 
a dot with a pencil. This dot may have a 
diameter of 0.2mm, but a point has no 
size. No matter how far you zoomed in, it 
would still have no width.] 

Points are not very exciting in Rhino, but 
they are important to keep in mind as 
we explore the basic tools they support. 
Points can be placed, but do not appear 
when rendering.
In Rhino, points can be connected up to 
form multi-segmented lines called curves.
The shape of the curve depends on the 
mathematical formula used to gener-
ate it. To the left you can see how the 
same control points generate different 
geometries based on the degree of the 
curve. The larger the degree of the curve, 
the greater the range of influence of the 
control points.
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Surfaces

Solids
In Rhino, surfaces can be joined to-
gether to form solids. Surfaces that 
have been joined to each other are 
called polysurfaces. There are many 
methods for creating solids, and 
here we will cover a few of them.

Solid Primitives – Box, Sphere, 
Cylinder, Cone, Truncated Cone, 
Pyramid
All of these commands will produce 
their related solid primitive. Check 
the command prompt for options 
related to each specific command.

“ExtrudeCrv” command:
Solids can also be created from 
a closed curve. Create a “Rect-
angle” and then “ExtrudeCrv.” If the 
capped option is active, the extru-
sion will have end caps as shown 
on the left. If the capped option is 
set to “no” then the extrusion will be 
open, as shown on the right.

“Slab” command:
Slab creates a “thickness” and 
“height” from a curve. You will be 
prompted to enter the thickness, 
the side where the offset should go, 
and the height, all at the command 
prompt.
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Surfaces

“Join” “Group” and “Explode” 
commands:
Make a box and “Explode” it. Notice 
that it is all separate planes. Select 
all of the planes and “Join” them. 
Now they are together again. Note 
that “Join” is about geometry group-
ing. If you “Group” the objects are 
related organizationally not geomet-
rically: they will all select together, 
and look exactly like a solid but they 
are NOT a solid, and you can NOT 
perform solid editing commands on 
a group.

“ExtractSrf” command:
Allows you to remove a surface 
from a joined object without explod-
ing it. Enter the command, pick the 
surface you want to extract, and hit 
enter. The surface will un-join the 
original solid.

“Cap” command:
Takes an open surface with planar 
holes and caps them, creating a 
solid object. Extrude a rectangle 
with the caps option set to “no”.  
Select the resulting surface and en-
ter the “Cap” command. The open 
rectangular polysurface should 
close into a solid.

“BooleanUnion,” 
“BooleanDifference” 
“BooleanIntersection”
Create a sphere and a box and 
intersect them. Now let’s Boolean 
these objects using each of the 
three commands.

“BooleanUnion,” 

“BooleanDifference 2” 

“BooleanDifference 1” 

“BooleanIntersection”



Object Manipulation

Object Manipulation

“Rotate 3D” command:
In order to rotate objects in 3D space 
you must use the rotate3D command. 
Execute the command then choose 
your objects to rotate. Choose the axis 
of rotation by specifying the first and 
second points to rotate around. This line 
WILL NOT MOVE. The object will rotate 
AROUND it. Imagine the earth. It spins 
in space, but at the absolute north pole, 
and the absolute south pole, the coor-
dinate do not change, only the orienta-
tion. The first line you are drawing is this 
axis of spin. You will then choose a point 
which will determine the reference angle 
for rotation. The last point you pick will 
determine the angle of rotation.

Orient Command:
 Orients an object to another by moving, 
copying, rotating and scaling the ob-
ject, using two reference and two target 
points.
1. Select one object.
2. Pick two reference points on the 
object.
3. Pick two target points on the second    
object: the first and second reference 
points will match these locations.



Surfaces

Surfaces
Just like points can be connected 
to form lines and curves, curves 
can be connected to form surfaces. 
Surfaces in rhino can be created in 
multiple ways. We will go through a 
few now. You can enter any of the 
following commands without the “” 
quotes in order to initiate the com-
mand.

“Plane” command:
Creates a planar surface element 
based on the coordinates entered.

“PlanarSrf” command: 
Creates a planar surface element 
based on a collection of planar 
curves.

“Loft” command:
Loft creates a surface between two 
or more curves that act as control 
geometry. Lofts can be planar (flat) 
or have 3D contours.

“ExtrudeCrv” command:
Allows a surface to be extruded up 
from a profile curve



Surfaces

Sweep1:
Create a rail curve and a profile. 
Think of the rail curve as the path 
that will be traveled, and the profile 
curve as the curve that will be trav-
elling on it (like a rollercoaster). The 
red path represents the profile curve 
in the example below. The options 
box controls may require some 
tweaking to get the desired effect. 
Use Command Help for an exhaus-
tive description of the options.

Sweep2:
Is very similar to sweep1, however 
you can select 2 rail curves to con-
trol your profile curves. Remember, 
the order is important. Select the 
2 rail curves FIRST, then select the 
profile curve.



Surfaces

Revolve:
Revolve is a command that creates a 
surface from profile curves, a revolution 
axis, and angle. First draw a profile curve 
that you want to revolve. Then click Re-
volve. Rhino then asks you for the curves 
to revolve. You can select more than 
one. Normally these curves are 2-dimen-
sional or flat, but they can also be 3D. 
Then choose a revolution axis. This is the 
axis around which our objects will rotate 
(think of a CD. A line drawn straight up 
and down through the center of the hole 
would be the axis of rotation). The length 
of this line is not important, only the 
direction. Then choose the angle through 
which you want to rotate the curves. 360 
is a full circle, 180 half a circle, and so on.

BlendSrf
Blend is a command that takes 2 differ-
ent surfaces and creates a third surface 
that literally blends between the first two. 
There are different options available for 
the blend, which we will cover here and 
that are also covered in the Command-
Help. Invoke the BlendSrf command. 
Rhino will ask you to choose the edges 
to blend together. Choose the two edges 
facing one another. Hit enter. Rhino will 
then present you with an options box, 
and several options from the command 
line. Notice the Continuity options are 
set to G2. The number describes how 
“strong” the influence is from that edge’s 
surface. Change the Continuity _1 from 
G0, one by one, to G4 to see how this 
affects the shape of the resulting surface. 
Move the sliders to change the strength 
of influence for each edge. You can also 
edit the handles directly to change the 
shape of the blended surface.
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Surfaces

ChamferSrf:
Chamfer creates a beveled edge 
on two adjacent surfaces. Invoke 
the ChamferSrf command. Rhino 
will then prompt you for the two 
surfaces to be chamfered. Choose 
the two surfaces and hit enter. After 
hitting enter, Rhino then prompts 
you for the distances to chamfer. 
You can cut more from one surface 
than the other if you make these 
distances unequal.

FilletSrf:
Fillet is much like chamfer in that 
it acts on two adjacent surfaces. 
Instead of producing a bevel, or cut;
however, fillet produces a radius 
joint. Invoke the FilletSrf command. 
Rhino will prompt you for two sur-
faces.
Choose the two surfaces and hit 
enter. Rhino will then prompt you for 
a radius to cut. Choose your radius
and hit enter.



Surfaces

Contour
Contour creates a series of 
cut planes through an object 
and makes curves at those 
locations. It is possible
to choose the distance be-
tween contours and their 
direction. Choose an object 
for contour. Invoke the
command. Choose the base 
point for the contour plane (it 
does not matter where this is). 
Choose a second
point. The second point deter-
mines the direction that the 
contours will be created, so if 
you choose a point
directly above the first point 
on the z-axis, your contours 
will all be made in the x-y 
direction. If you set the
JoinCurves option to ByCon-
tourPlane, each contour curve 
will be a single object. When 
you hit enter, the
command will generate con-
tour curves.
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Surfaces

Explode:

Explode will take a solid object and 
separate it into its constituent parts. For 
instance a cube would become
6 separate surfaces when exploded. 
Sometimes this is useful because we 
want access to each side individu-
ally. More often than not, however, it is 
easier to work with one side at a time. 
We can extract sides individually by 
using:

Commands that work similarly in 
AutoCAD and Rhino for you to 
try:

Trim, extend (works with surfaces as 
well), stretch, scale, rotate (in addition 
to rotate3d), mirror, array, chamfer and 
fillet (works with curves as well),

Commands that are new but 
work like commands we have 
already covered to try:

Curveboolean – Booleans with curves

Moveedge – Move the edge of a sur-
face

Maelstrom – Rotates part of a surface, 
solid, or curve leaving the rest 
stationary

Arrayhole – Creates an array of holes in 
a solid or surface

Deletehole – Removes a hole in a solid 
or surface

Rotateedge – Rotates an edge of a 
surface

Rotateface – Rotates a face in a solid

Rotatehole – Rotates a hole in a 
surface or solid



Creating Objects Using Boolean Commands

To create an object in Rhino, 
click on one of the Solids 
from the solids tool pallet:

This box is defined by two points 
and a height. 

•	 Height 

•	 Two base points

Note, use multiple windows to cre-
ate your box. Define the base points 
in either the top view or the per-
spective view, then activate ortho at 
the bottom of the modeling window, 
and then extrude the box in either 
front or side view.

Creating complex objects in Rhino 
is easy to do using the boolean op-
erations. Simply build the object you 
want to cut and place it in the correct 
location relative to the object you 
want to keep.

•	 Object to cut (Shown high 
lighted)

•	 Object to keep

•	 Cut object



Adjusting Surfaces by Editing its Control Points

Along with normal objects, 
you can adjust “blobs.” Start 
with a sphere. Click on the 
solids menu>Sphere>Center, 
Radius. Click in the screen 
and draw a sphere.

•	 You can now move the control 
points that define the sphere 
by clicking on the point editing 
tool. With the sphere selected, 
click on this tool to turn on point 
editing.

Now in plan or front view select a 
series of points. Then click and drag 
the points stretching out the sphere.

Note: This will not work with rectan-
gular solids, but will work
with spheres and surfaces..

•	 Control points on, and some 
points selected:

•	 Selected points moved and 
sphere is deformed 

•	 Rendered Sphere.

This process can be applied to 
almost any Nurbs surface.
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Lofting a Surface

Advanced modeling features

Some of the features below are 
very specific to Rhino. Others will 
appear as variations of tools in 
other modeling programs. 

Lofting a Surface 
The term lofting comes from the ship 
building industry. This is the method of 
placing a surface over a ship skeleton. In 
Rhino you generate a lofted surface over 
a series of curves spaced out. To loft a 
surface, create a series of splines, and 
arrange them to define the soon to be 
formed surface.

Select Surface>Loft. At the command 
prompt, click on the splines in the correct 
order. Click Enter or Right Click when 
done. The following window will appear: 
(Note, click to one side of the lines to set 
the direction of the loft) Now in plan or 
front view select a series of points. Then 
click and drag the points stretching out 
the sphere.
•	 The Loft Options box will appear. 
•	 Under the Style drop down you will 

have a number of loft options:

•	 Normal: The most mathematically efficient loft 
•	 Loose: Will create a smoother loft that is not based exactly 
       off of the loft curves, but averaged. 
•	 Tight: Constructs a loft that is exactly on the various loft curves
•	 Straight Sections: Will create a series of
       ruled surfaces between loft lines
•	 Developable: Will create lofts that can be flattened out on a single 

sheet.
•	 Uniform: Guarantees that every control point affects the surface 
       exactly the same way.
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Lofting a Surface
Rebuilding Surfaces

•	 Selecting this will create a 
closed lofted surface. Check 
and click preview to see. 

•	 Align Curves: This is used to flip 
the direction of a curve. 

•	 Rebuild With Control Points. 
This allows you to set a number 
of curve divisions refining the 
smoothness of the surface. 

Set the loft to rebuild with 20 points 
and click Preview to see the sur-
face. If you like it, click OK. 

•	 The Lofted Surface

Rebuilding Surfaces: 
Often after you create a curve or 
surface, you will need to rebuild 
it. Rebuilding a curve or surface 
changes the number of points in 
a curve or the number of points in 
a profile curve used in creating a 
surface. Each point then has a line 
(Iso-curve) running through it. Re-
building a curve or surface changes 
the number of points in each line. 
This will, in effect, make the curve or 
surface smoother (reducing points) 
or more flexible (increasing curves)

Select a surface or curve, then click 
on Edit>Rebuild 
•	 Change the number of points in 

both the U and V Directions 
•	 Keep the Curve Degree to 3 or 

lower typically 
•	 Click Preview to preview the 

new Curve or Surface. Click OK 
to rebuild.



Rebuilding Surfaces and Curves
Trim and Split

•	 Rebuilt Curve with only 6 control 
points

•	 Original Curve with 16 Control 
Points

•	 Original Surface with 20 Control 
Points

•	 Same Surface “Rebuilt” with 
only 6 control points

Trim and Split:
When dealing with complex sur-
faces, you will most likely need to 
cut holes and trim surfaces. This 
can be done with the boolean tools, 
but there are times when they do 
not provide the level of detail that 
the trim and split tool offer. Trim and 
Split are basically the same tool, the 
only difference is that the trim tool 
will delete the piece being cut. Split 
will just cut the objects.

•	 Trim
•	 Split

•	 In this example, I have placed 
a cylinder through a lofted 
surface.



Trim and Split

•	 Click on the Split Tool.

At the prompt, click on the lofted 
Surface--the object to be split.
 
Click Enter. 

Then Click on the Cylinder. This is 
the object to cut. 

Click Enter to split the object 

•	 The Object Split (Note: I deleted 
the cylinder but there are two 
objects remaining.) 

The Trim Tool will automatically 
delete the cutting object. Also in 
this example, I just have the circle-
shape. I do not need to extrude a 
cylinder through the lofted shape.

•	 Click on the Trim Tool 

At the Prompt: Select Cutting 
Objects, choose the Circle and hit 
Enter.

At he Prompt: Select object to Trim, 
select the lofted surface

NOTE: Do this through the Front El-
evation, otherwise the lofted shape 
would be cut through the perspec-
tive view. 

•	 Note: If you click on the lofted 
shape inside the circle, the 
inside circle will be deleted. If 
you click outside the circle, the 
outside will be deleted.



Trim and Split
Patching a Surface

•	 Trimmed by clicking inside the 
circle

•	 Trimmed by clicking outside the 
circle

Patching a Surface: 
Patching a surface is used to create 
a uniform surface from a series of 
closed curves. The most common 
use for this tool is generating terrain 
models.

Select Surface>Patch

•	 At the Patch prompt, click in 
order the closed curves to be 
patched.

Adjust the setting to get the desired 
result. Click on the preview button 
to see a preview of the patched 
surface.

Click OK to generate the patched 
surface.
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Duplicating and Projecting Curves onto Surfaces

Duplicating and Projecting 
Curves onto Surfaces:
You can generate curves from exist-
ing geometry and then project that 
onto other geometries. 

In this example, I have added a 
plane to the model with the trimmed 
lofted surface. I am going to project 
the holes onto the surface.

•	 Surface to project the curve 
onto 

•	 Lofted Surface with the hole

Step One: 
Duplicate the Edge of the hole. 
Click on Curve>Curve From 
Objects>Duplicate Edge

At the Command Prompt, select the 
edge to duplicate. Note: Sometimes 
you will have to click on many seg-
ments of an edge to duplicate. If 
this is true, you will also need to join 
the segments after they are dupli-
cated into one singe curve.



Duplicating and Projecting Curves onto Surfaces

Step Two: 
Project the duplicated edge curve 
onto the surface.

Select Curve>Curve From 
Objects>Project.

At the Command Prompt, Select 
Surfaces...to project onto, select the
surface.

NOTE: You have to do this through 
an orthogonal view. If you do it in
perspective view, it will perspectively 
project the curve.

•	 Click the Surface to project onto 
in an orthogonal view

•	 The curve projected onto the 
surface.

Delete the surface and you are left 
with the projected curve.

•	 Lofted Surface

•	 Filleted Surfaces

I lofted the two Edge curves and 
filleted the intersection of the two 
lofted surfaces.



Capping Holes and Generating Surfaces from Edge Curves

Capping Holes and Gener-
ating Surfaces from Edge 
Curves:

Often you will need to cap holes. If 
the curves that make up the edge 
of the hole are planar (They all fall 
inside a single plane), you can use 
the Planar Holes tool.

•	 Select Surface>Planar Curves.

•	 Select the curves to cap and 
Hit Enter. (Note: You can select 
more than one curve.)

•	 Capped Surface

To cap a non-planar surface, you 
will need to use the Edge Curves 
tool. The problem with the edge 
curve tool is there is a limit to the 
number of curves you can select 
(only 2-4 curves) To get around 
this you can join additional curves. 
However, the result can be less then 
satisfactory.

A common use for the Surface 
From Edge Curves is to box out two 
surfaces.

•	 Use this tool to create surfaces 
along the two edges of the 
existing surfaces. (Note: You 
could loft it but it is hard to do it 
on all four sides.
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Capping Holes and Generating Surfaces from Edge Curves

Step One: Snap Curves between 
the two Surfaces.

Using the curve tool, and with the 
end point O-Snap active and Proj-
ect off, snap two lines between the 
two surfaces.

•	 Two Curves Drawn between the 
two surfaces.

•	 Step Two:  Activate the Edge 
Curves tool by Clicking on 
Surface>Edge Curves

Select the 2 Curves
and 2 Edges that will
make up the surface.

The surface is created.

•	 Model with all four surfaces 
created



Object Manipulation using Caging

Caging allows you to transform a 
complex object using a small num-
ber of edit points.

Caging is a two step process, first 
you define the shape (Cage) that 
will be used to box around the ob-
ject and transform it.

To do this select Transform>Cage 
Editing>Create Cage

At the prompt, draw a 3-point box 
around the object and hit Enter. A 
box is formed around the object.

The next step is to Edit the Cage 
which will transform the object.

Click Cage Editing>Cage Edit.

At the prompt, Select Captive Ob-
jects, select the objects to trans-
form.

At the next Prompt, Select Control 
Object, select the caged box.

At the next Prompt, select Global, 
and points are created throughout
the cage.

•	 Select Points in the cage and 
move the points

•	 Transformed Object
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CageEdit

We will explore the options involved 
in a CageEdit in this section. While 
we will cover these commands in 
a detailed way, there is additional 
explanation and video help avail-
able in the CommandHelp in Rhino. 
Start with a text object: it has a fairly 
complex geometry, and since  the 
shape of letters is familiar, it will be 
easy to distinguish the changes 
taking place. TextObject will allow 
us to make 3D text. Now invoke the 
CageEdit command. 

The following options will appear 

The control object is the object that 
we will edit in order to change the 
target objects. Let’s choose Bound-
ingBox for the time being. Bound-
ingBox automatically generates 
a box that surrounds the objects 
selected.  Rhino will then prompt for 
a coordinate system. World is the 
default, but you can also choose C-
plane, if you have defined a custom 
C-plane in your viewport. We will 
be working with the world coordi-
nates for these examples. Rhino 
now prompts you for the number of 
cage points in the x, y, and z points. 
These directions correspond to the 
world or c-plane axis depending 
on your previous choice. Choose 
the default of 4 points and hit enter. 
A cage with corresponding points 
will appear in Rhino. Pulling these 
points will change the shape of all 
of the letters within the cage.
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CageEdit

Now try it with a different control 
object. Use the Box option to create 
a box that is located away from the 
text. For all of the remaining op-
tions use the same settings so it is 
possible to see what just this single 
change can do. When prompted, 
choose Global as the Region to 
Edit. When we deform the control 
object, the changes to the target 
object are very drastic. As a rule, 
the further away from the control 
object you are, the stronger the 
changes. 

Now create another CageEdit using 
Box as the control geometry. Place 
a portion of the object within the box 
and a portion of the text outside of 
it. Again, choose the same options 
as before, but this time, choose 
Local as the Region to Edit. You will 
be prompted for a falloff distance. 
The larger this number, the more of 
the geometry outside of the box will 
be affected. The upper image was 
created with a smaller falloff than 
the image below.



Control Points

In addition to controlling one 
geometry with another, we can 
directly edit the points that make up 
a surface or a curve, as we saw last 
week. Move, scale, bend, rotate, 
and all many other tools also work 
on control points. To turn on the 
control points for a surface, hit F-10. 
To turn them off hit control F-11.

Selu/Selv
You can select an entire row of 
control points by selecting a single 
point, and then running the SelU or 
SelV command.

SetPt
You can align a series of points 
by running the SetPt command. 
Choose the points you would like to 
align and then enter an orthogonal 
viewport. Invoke the SetPt com-
mand. A dialog will appear. Choose 
the axis to align on, hit ok, and 
then choose a single location for 
the group of aligned points in the 
viewport.
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Smooth

Smooth:
It is also possible to smooth a 
surface. Choose the control points 
to smooth, and then invoke the 
Smooth command.  A dialog box 
appears asking which direction to 
smooth. You can choose any com-
bination of x, y, and z. The smooth 
factor controls how much the sur-
face control points are smoothed.

SoftMove

Weight – control point weight dialog

Edit>Control Points>Insert con-
trol point u or v toggle direction, 
changes shape
InsertKnot inserts control points and 
maintains shape of surface



Blend Surface Feature

Blend Surface Feature:
Rhino has a number of tools to 
match up two separate surfaces. 

These are located in the surface 
tools pallet, or in the surface pull 
down menu. 

•	 Fillet Surface

•	 Blend Surface

These are two surfaces that I want 
to blend together to create a single 
surface that will transition the two 
surfaces.

Step One: 
Select “Surface” from the menu bar, 
and then “Blend”.

Step Two: 
In the command prompt at the top 
of the window, under “Select First 
Set of Edges”, click on the edges of 
the first surface to blend. After you 
have selected all of the edges, hit 
return or right click.



Blend Surface Feature

The command prompt will now 
say “Select Second Set of Edges”. 
Select the second set of edges, and 
hit return or right click.

Step Three: 
At the command prompt “Select 
Seam Point to Adjust. Press Enter 
When Done” you will get some ad-
ditional options. You will also notice 
that you will get two arrows. These 
arrows allow you to adjust the 
location of the seam to the blended 
surface and adjust the direction of 
the surface.

•	 Two Arrows

•	 Seam of Blended Surface 
Adjusted.

.
Also in this command prompt 
you will notice three options “Flip 
Direction, Automatic, and Natural” 
The flip direction option allows you 
to orient the arrows in the same 
direction to avoid a twisted surface. 
Automatic will generate the surface 
automatically. Natural will give a 
more relaxed look to the surface. 
Click Enter to Continue.

•	 A preview button will appear 
where you can adjust the set-
tings.

•	 Generated Surface



Using Blocks in Rhino

Using Blocks in Rhino:
Often you will use the same part 
created in Rhino many times. If this 
is the case it is best to use blocks. 
Blocks have two major advantages:

1. It keeps the files sizes small and 
thus you can create complex mod-
els without having large files sizes.

2. If you need to update the part, 
all the instances of that part will be 
updated.

•	 Complex Form that will be 
turned into a block.

Select Edit>Blocks>Create Block 
Definition.

At he prompt, select objects to 
define block, click on objects and 
hit Enter.

At the Prompt, define base point, 
click to set an insertion point for the 
block.

The following window will appear:

The block Definition properties will 
appear.

•	 Give the block a Name and hit 
OK.



Using Blocks in Rhino

Inserting a Block Definition:

After you create a block, you can 
then insert instances of the block 
into the Rhino model. An instance 
is a reference of an original. This 
is how you can keep the file sizes 
down.

•	 Choose the Block to insert

•	 Select Various insertion settings

•	 Click OK to insert

•	 The block will be bound to the 
mouse and when clicked, will 
be inserted



Using Blocks in Rhino

Linking External Models as 
Blocks:

Another powerful way to use blocks 
is to link a series of external models 
into a “Master” Rhino Model. This 
allows updates in different models 
to be automatically updated in the 
master model.

•	 Step One: Create a Block 
from an external file. Select 
Edit>Blocks>Insert Block 
Instance

•	 Select File

•	 Select a Rhino Model to insert



Using Blocks in Rhino

•	 Linked File Name and Pathway 
is displayed

(NOTE: It is a good idea to keep 
all files in the same folder to avoid 
broken links)

•	 Under External File, Choose 
Link

•	 Click OK to place in model

•	 Linked Models

If changes are made in the original 
model the changes will appear in 
the model with the block definitions.

•	 Change Made to Original Model 
File

•	 To update the Link Model, click 
on Edit>Blocks>Block Man-
ager

•	 Select the Block to Update, and  
click on Update.

•	 Blocks are Updated
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Make A 2D Drawing:

In Rhino you can generate a series 
of 2D Drawings from 3D forms.  
These drawings are a series of 2D 
curves that can be imported into 
Illustrator or Flash.

•	 To make a 2D drawing, click on 
Dimensions>Make 2-D Draw-
ing.

At the prompt, select objects to 
draw, and select the objects.

The following Window will appear:

•	 Choose 4 View USA

•	 Click OK

•	 Four Views, Top, Front, Left, 
and Perspective are created. 

These views are located on the 
ground plane. If you select a view 
and export it from the top view it will 
be oriented in the correct direction.



Basic Rendering

Basic Rendering

Key – The key light is the main light 
and should be approximately twice 
as bright as your fill light for regular 
scenes, but can be up to 8 times as 
bright for dramatic shadows.
Fill – The fill light helps to bring up 
the level of the shadows.
Back – The back light should be 
bright enough to create a light halo 
around the back and side of your 
rendered object.

Basic Lights: 
Directional – Light that is similar to 
the sun (it fills the render space with  
a uniformly intense amount of light) 
and creates a directional shadow

Spot – Light that is similar to a 
stage spot-light. This has a limited 
range of effect, so objects outside 
of it will not be lit.

Point – Like a candle flame or light 
bulb. Light radiates from a point. 
Limited range.

Rectangular – Light radiates from a 
plane.

Linear – Light radiates from a line.

Set the Renderer to Rhino renderer 
by going to : Render> Current Ren-
derer> Rhino Render

In this dialogue, you can change the 
resolution of your image, the back-
ground color,  set a background 
image, and change other options.



Layouts

Constructing Page Layouts for 
Printing, Background colors, and 
Orienting objects

1. Select View > Page Layout > New 
Page Layout

2. In the New Page Layout dialog, choose 
printer (or None), set the paper size to 
11 x 17” landscape, set the Initial Detail 
Count to 4, and click on the OK button. 
The four viewports open at this time in 
your drawing will appear in the layout 
viewports. 

The Initial Detail Count refers to the 
number of detail viewports that will be 
constructed automatically by the system. 
If you choose 0, you will have a blank 
page layout. 

3. To manipulate the viewports, activate 
it by double clicking inside it: you can 
rotate, pan, zoom, and orbit, or by choos-
ing the “Select View” icon, change to a 
different view. 

4. To lock at a detail, so the selected view 
is not altered, select the edge of its box (it 
will turn yellow), go to the Properties list, 
select detail, and in the dialogue box and 
check “Lock”.

5. To add shading to a viewport, double 
click on the viewport to enable it. Then left 
click on the shaded viewport command 
icon.    

Background color
Background colors for the screen are 
found in the Options > Appearances > 
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AutoCAD to Rhino
Cleaning your AutoCAD drawing is 
one of the most important parts of the 
process. A clean .dwg will allow you 
to easily produce a 3D model, while 
a messy .dwg can cause many head-
aches in the long run.

Make a Copy of your Files:
Before you make any changes to your 
file, it is recommended that you use 
File>SaveAs to create a second set of 
files that will become your underlay for 
modeling by appending something to 
the end of the filename. This is impor-
tant as you do not want to modify your 
working drawings accidentally.

NOTE
It is recommended that you choose Au-
toCAD 2004 as your filetype when you 
SaveAs. The 2007 and 2010 filetypes 
WILL typically NOT import into Rhino.

Delete Unneeded Information
It is important that we remove any ex-
traneous information from the drawing:

Text and Dimensions:
Delete all text and dimensions. You will 
not need them in Rhino and they will 
only serve to cause you
headaches if you leave them in your 
drawing.

Layers:
It is time to leave your layers behind. 
Turn on all of your layers (assuming 
that you need all of them in your model) 
and change all of your layers to layer 
0. You’ll likely find that you have some 
objects that still appear

to be on a layer. These are probably 
blocks that have been improperly 
made. We will deal with blocks next.

Blocks:
You may find that the drawings you are 
working with use blocks for washrooms 
or bathrooms, kitchens, furniture, scal-
ies (people) and other non-architectural 
elements. It is best to remove all of 
these blocks from the drawing by delet-
ing them. Blocks are also often used to 
simplify the process of drawing com-
plex geometry. These blocks should be 
simplified (by editing the block directly 
or using bedit) and then exploded
using explode.

You may need to Edit>Select All and 
change the layer of your objects to 0 
one more time, as blocks can have 
objects set to different layers nested 
inside them.

NOTE 
It is better to delete your unneeded 
blocks before exploding them as you 
will often have a hard time
cleaning up your drawing should you 
explode first.

Hatches:
Next, we will want to make sure that we 
clean up any hatches from the drawing. 
You should just delete these objects 
unless they are highly specific (a brick 
pattern that has been PROPERLY ap-
plied at the right scale.) IF and ONLY IF 
you absolutely need a hatch (think long 
and hard about this), you can explode 
that hatch and it will import into Rhino.

Helpful Commands:
Purge, Qselect, Overkill

After deleting the above objects (block 
instances, hatches, and objects on 
unneeded layers) you will want to 
purge the file. This helps ensure that 
your Rhino file will not have hundreds 
or possibly even thousands of unused 
block definitions, layers, hatch defini-
tions, etc. taking up space and slowing 
down your model.



AutoCAD to Rhino

Open Rhino and Choose 

File>Import:
Make sure that you choose Auto-
CAD drawing file in the type drop-
down.

Your geometry should appear in 
your Rhino model. Before doing 
anything else, group the drawing. 
This will allow you to select it as an 
object, rather than line by line.

Create a new layer (right click on 
the layer palette> New Layer):

and place your plan on it (select the 
plan, right click the layer you made 
and choose Change Object Layer):

Verify your units and dimensions 
match in AutoCAD and Rhino by us-
ing the distance command in both
AutoCAD and Rhino on the same 
geometry.

Now we want to simply repeat the 
process with each of the underlay 
drawings you will be using.



For some of you who are coming 
from AutoCAD 3D or SketchUp, the 
workflow in Rhino may be a bit for-
eign. This worksheet will describe 
two possible methods for drawing in 
3D space. 

This is the default setup for viewports, 
which will be familiar to many of you. 
Each view is linked to a camera, and 
can be changed by right clicking on 
any of the viewport names.

It is best to understand how to draw 
in 3D fairly early, usually right after 
exploring the interface. In this view-
port, I’ve drawn a line, which ap-
pears to be starting on the grid, and 
extending upward in the Z direction.

This is the reality. In general, when 
you draw in a viewport. Unless you 
specifically tell Rhino to draw in the 
3rd dimension or OSnap to another 
object, you will be drawing on the 2D 
construction plane (the plane of the 
gray grid—called the CPlane from 
here on) shown in the view.

Interface



The first way to draw vertically (or in the 3rd 
dimension not represented by the CPlane, as 
this is possible in any viewport) is to use the 
vertical command line option when invoking a 
command. Many very basic commands have 
this option.  

The second is the coordinate system. When 
drawing a curve, for example, you are able to 
input coordinates for points using the com-
mand line in the x,y,z format. This is going 
to use the coordinate system defined by the 
CPlane of the viewport you are working in. If 
you modify the CPlane, make note of this!
The third is to draw objects to use as a tem-
plate flat on the CPlane and to simply rotate 
them in 3D the appropriate amount. This can 
take some time (you are still only drawing in 
2D and then often need to model further af-
ter placing your templates) but can be a valid 
method for working with certain object pro-
files.
The fourth involves modifying the CPlane and 
can be difficult for some students to master. 
(This is generally an intermediate skill: intro-
duced this after one has grasped the idea 
of how the viewports are working, and feels 
comfortable creating 3D geometry). You can 
create a mobile construction plane tied to a 
piece of geometry that you can then use to 
edit your project:

Right clicking on a viewport brings up the fol-
lowing context menu where you can change 
viewport properties and edit which camera is 
being used. It also provides us with the option 
of creating a mobile CPlane.

If we have the following geometry, and we 
want to create a mobile CPlane in the Front 
view, we invoke the command and see the fol-
lowing prompts:

Interface



We then choose the geometry to 
represent our mobile CPlane. I’ve 
chosen the small rectangle. 

We will then be prompted to choose 
a coordinate system starting with the 
origin, and proceeding to the axes.

We will then be prompted if we want 
the CPlane to automatically update 
when we move the geometry.

Saying yes will cause the CPlane to 
move when the geometry moves, as 
can be seen here.

Remember to think about breaking 
down modeling problems as a set 
of procedures. There are many ways 
to create a piece of geometry and it 
is best to approach any object that 
needs to be created as a problem 
that needs to be solved. Often one 
will see the end goal and not be able 
to get beyond it’s complexity. Even 
the most complex objects can be 
broken down into a series of simpler 
operations.

Interface
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Tips for Users of Rhinoceros for 
Creating Models for 3D 
Printing
Rhino can be a valuable tool for both 
the creation of 3D mesh and as a tool 
for conversion of parametric based 
geometry to polygon geometry. Rhino 
also imports a large number of file 
formats, which can be converted to the 
.stl file format.

Exporting to .stl
Prior to exporting to .stl format follow 
these diagnostic tool to check the qual-
ity of the solid.
.stl Mesh Export Diagnostics
For some rapid prototyping machines, 
.stl files must contain completely 
closed (watertight) polygon mesh 
objects. You might want to do this to 
make sure the meshes really do fit 
together before exporting them for use 
in an expensive .stl job. Use Join, then 
Weld (angle=180), UnifyMeshNormals 
to turn a group of meshes into a single 
watertight mesh object. Then use 
SelNakedMeshEdgePt to find the open 
(naked) edges.

Watertightness
•	Select	the	mesh	objects.
•	From	the	Edit	menu,	click	Join.
•	Conceptually	this	gets	all	the	tri-
angles into one bag, but does not glue 
the edges together. (The situation is 
similar to having a bunch of surfaces 
that all fit together but have not been 
joined into a Solid.)
•	Select	the	new	mesh	object.
•	From	the	Tools	menu,	click	Polygon	
Mesh, then click Weld.
•	At	the	Angle	tolerance	prompt	type	

180. An angle tolerance of 180 tells 
the Weld command to glue adjacent 
triangle points together no matter what.
•	From	the	Tools	menu,	click	Polygon	
Mesh, then click Unify Normals. This 
changes all the triangles so they are 
oriented the same way, that is, if two 
triangles share an edge, then they have 
the same idea of up.
•	To	see	if	the	result	has	any	holes	or	
gaps, type SelNakedMeshEdgePt. If a 
mesh point is highlighted, then it is part 
of a “naked” triangle edge.

Note
When exporting NURBS objects to .stl, 
Rhino converts the NURBS objects to 
polygon mesh objects. If Rhino can-
not create a closed .stl file, the Export 
Incomplete Solids dialog box asks if 
you want to export anyway.
The tolerances you set in the Docu-
ment Properties dialog box, Units page 
do not affect the .stl export tolerance. 
Instead, to control .stl accuracy, use 
the mesh tolerance settings from the 
Detailed Controls section of the mesh 
dialog that appears during .stl export. 
Set the Max distance edge to srf value 
to the .stl tolerance you desire.

Weld Polygon Meshes
•	Select	the	group	of	polygon	meshes	
objects.
•	At	the	Angle	tolerance	prompt,	enter	
a maximum angle between mesh poly-
gon normals where welding of points 
should occur. If two naked mesh edge 
points of a selected mesh are coinci-
dent and their neighboring faces are 
within the angle tolerance of each other, 
they are replaced by a single mesh 

point. If the two points were from differ-
ent “sub-meshes” of a joined mesh, the 
meshes become one mesh that cannot 
be exploded.
•	To	perform	a	similar	operation	with	
control points, see the SetPt command. 
Welding polygon meshes affect render-
ing, texture mapping on mesh objects, 
and file export for stereolithography.

Unify Normals
UnifyMeshNormals is primarily for mak-
ing sure the order of the vertices in all 
polygons in welded polygon meshes 
are the same.
•	Select	a	single	unjoined	mesh.	The	
normals of all the faces of the mesh 
now point to one side of the mesh.
The UnifyMeshNormals command 
changes the direction of the surface 
normals of a mesh object so they all 
face the same direction. This com-
mand is useful for tidying up your mesh 
objects for export into 3D Studio.
To test if the mesh needs to be unified:
•	File	menu:	Properties
•	On	the	Render	page,	clear	the	Ren-
der Backfaces checkbox.
•	Render	your	mesh.	If	some	of	the	
faces that should render disappear, 
their normals are flipped. Use UnifyMe-
shNormals to make them all match.

Note
If UnifyMeshNormals does not seem 
to affect your mesh, explode it. Once 
the normals are correct, re-join the 
meshes.
A polygon can have two types of nor-
mals: vertex normals and a face nor-
mal. All polygons have a face normal 
direction, but many polygon meshes do 

not have vertex normals. For example, 
3DFace object, all mesh primitives and 
all polygon meshes imported in formats 
other than 3DM and 3DS do not have 
vertex normals at all.
In general, the order of the vertices in 
a polygon determines the face normal 
direction. The order of the vertices 
should be either clockwise or coun-
terclockwise. The normal direction is 
determined from the vertices using the 
right hand rule.

Select Naked Edge Points
The selected naked edge points com-
mand shows where polygon mesh 
vertices are not completely surrounded 
by faces. Joined meshes, such as are 
made by Mesh Box, have naked mesh 
edge points where the sub-meshes are 
joined.
To eliminate naked mesh edge points, 
move them to make them match in 
pairs, then weld them to make a single 
mesh that cannot be exploded. Edges 
that formerly rendered sharp will shade 
rounded, unless you use FlatShade.
•	.stl	Tools	toolbar:	Show	and	Select	
Naked Mesh Edge Points
Command line: SelNakedMeshEdgePt
•	Select	polygon	meshes	for	naked	
edge point search prompt, select poly-
gon meshes and press Enter. Points at 
edges of polygon meshes are selected.


